summaryrefslogtreecommitdiffstats
path: root/common/recipes-rest/bottle/bottle_0.12.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-rest/bottle/bottle_0.12.7.bb')
-rw-r--r--common/recipes-rest/bottle/bottle_0.12.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/common/recipes-rest/bottle/bottle_0.12.7.bb b/common/recipes-rest/bottle/bottle_0.12.7.bb
new file mode 100644
index 0000000..25bd547
--- /dev/null
+++ b/common/recipes-rest/bottle/bottle_0.12.7.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bottle Web Framework"
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://bottle.py;beginline=1;endline=14;md5=15d806194a048a43e3a7f1d4c7574fe6"
+
+SRC_URI = "https://pypi.python.org/packages/source/b/bottle/${PN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "ed0b83c9dbbdbde784e7c652d61c59f4"
+SRC_URI[sha256sum] = "e3ea2191f06ca51af45bf6ca41ed2d1b2d809ceda0876466879fe205be7b2073"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+dst="/usr/lib/python2.7"
+
+do_install() {
+ mkdir -p ${D}/${dst}
+ install -m 755 bottle.py ${D}/${dst}
+}
+
+FILES_${PN} = "${dst}"
OpenPOWER on IntegriCloud