summaryrefslogtreecommitdiffstats
path: root/common/recipes-lib/ipmb/libipmb_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-lib/ipmb/libipmb_0.1.bb')
-rw-r--r--common/recipes-lib/ipmb/libipmb_0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/common/recipes-lib/ipmb/libipmb_0.1.bb b/common/recipes-lib/ipmb/libipmb_0.1.bb
new file mode 100644
index 0000000..81eed9c
--- /dev/null
+++ b/common/recipes-lib/ipmb/libipmb_0.1.bb
@@ -0,0 +1,26 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+SUMMARY = "IPMB Client Library"
+DESCRIPTION = "library for IPMB Client"
+SECTION = "base"
+PR = "r1"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://ipmb.c;beginline=8;endline=20;md5=da35978751a9d71b73679307c4d296ec"
+
+
+SRC_URI = "file://Makefile \
+ file://ipmb.c \
+ file://ipmb.h \
+ "
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 0644 libipmb.so ${D}${libdir}/libipmb.so
+
+ install -d ${D}${includedir}/openbmc
+ install -m 0644 ipmb.h ${D}${includedir}/openbmc/ipmb.h
+}
+
+FILES_${PN} = "${libdir}/libipmb.so"
+FILES_${PN}-dev = "${includedir}/openbmc/ipmb.h"
OpenPOWER on IntegriCloud