summaryrefslogtreecommitdiffstats
path: root/common/recipes-lib/gpio/libgpio_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-lib/gpio/libgpio_0.1.bb')
-rw-r--r--common/recipes-lib/gpio/libgpio_0.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/common/recipes-lib/gpio/libgpio_0.1.bb b/common/recipes-lib/gpio/libgpio_0.1.bb
new file mode 100644
index 0000000..cd32ac0
--- /dev/null
+++ b/common/recipes-lib/gpio/libgpio_0.1.bb
@@ -0,0 +1,40 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+SUMMARY = "GPIO access library"
+DESCRIPTION = "library to access GPIO"
+SECTION = "base"
+PR = "r1"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://gpio.c;beginline=4;endline=16;md5=da35978751a9d71b73679307c4d296ec"
+
+SRC_URI = "file://src \
+ "
+
+DEPENDS += "liblog"
+
+S = "${WORKDIR}/src"
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 0644 libgpio.so ${D}${libdir}/libgpio.so
+
+ install -d ${D}${includedir}/openbmc
+ install -m 0644 gpio.h ${D}${includedir}/openbmc/gpio.h
+}
+
+FILES_${PN} = "${libdir}/libgpio.so"
+FILES_${PN}-dev = "${includedir}/openbmc/gpio.h"
OpenPOWER on IntegriCloud