From 78b9749c0a4ea980a8b934645da6ae98fcc665e8 Mon Sep 17 00:00:00 2001
From: dim <dim@FreeBSD.org>
Date: Wed, 6 Jan 2016 20:12:03 +0000
Subject: Vendor import of lldb trunk r256945:
 https://llvm.org/svn/llvm-project/lldb/trunk@256945

---
 .../data-formatter/summary-string-onfail/Makefile  |  12 ++
 .../summary-string-onfail/Test-rdar-9974002.py     | 133 +++++++++++++++++++++
 .../data-formatter/summary-string-onfail/main.cpp  |  30 +++++
 3 files changed, 175 insertions(+)
 create mode 100644 packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Makefile
 create mode 100644 packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Test-rdar-9974002.py
 create mode 100644 packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/main.cpp

(limited to 'packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail')

diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Makefile b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Makefile
new file mode 100644
index 0000000..04f3927
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Makefile
@@ -0,0 +1,12 @@
+LEVEL = ../../../make
+
+CXX_SOURCES := main.cpp
+
+# clang-3.5+ outputs FullDebugInfo by default for Darwin/FreeBSD 
+# targets.  Other targets do not, which causes this test to fail.
+# This flag enables FullDebugInfo for all targets.
+ifneq (,$(findstring clang,$(CC)))
+  CFLAGS_EXTRAS += -fno-limit-debug-info
+endif
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Test-rdar-9974002.py b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Test-rdar-9974002.py
new file mode 100644
index 0000000..2873e35
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/Test-rdar-9974002.py
@@ -0,0 +1,133 @@
+"""
+Test lldb data formatter subsystem.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class Radar9974002DataFormatterTestCase(TestBase):
+
+    # test for rdar://problem/9974002 ()
+    mydir = TestBase.compute_mydir(__file__)
+
+    def setUp(self):
+        # Call super's setUp().
+        TestBase.setUp(self)
+        # Find the line number to break at.
+        self.line = line_number('main.cpp', '// Set break point at this line.')
+
+    def test_with_run_command(self):
+        """Test that that file and class static variables display correctly."""
+        self.build()
+        if "clang" in self.getCompiler() and "3.4" in self.getCompilerVersion():
+            self.skipTest("llvm.org/pr16214 -- clang emits partial DWARF for structures referenced via typedef")
+
+        self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+        lldbutil.run_break_set_by_file_and_line (self, "main.cpp", self.line, num_expected_locations=1, loc_exact=True)
+
+        self.runCmd("run", RUN_SUCCEEDED)
+
+        # The stop reason of the thread should be breakpoint.
+        self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+            substrs = ['stopped',
+                       'stop reason = breakpoint'])
+
+        # This is the function to remove the custom formats in order to have a
+        # clean slate for the next test case.
+        def cleanup():
+            self.runCmd('type summary clear', check=False)
+
+        # Execute the cleanup function during test case tear down.
+        self.addTearDownHook(cleanup)
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer.first}\" container")
+     
+        self.expect('frame variable mine',
+            substrs = ['mine = ',
+                       '1', '<parent is NULL>'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer%S}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s foo contained")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', 'foo'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', 'foo'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer%V}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer.first}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '<parent is NULL>'])
+
+        self.runCmd("type summary delete contained")
+        self.runCmd("n")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '<parent is NULL>'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer%S}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s foo contained")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', 'foo'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', 'foo'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer%V}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '0x000000'])
+
+        self.runCmd("type summary add -s \"${var.scalar} and ${var.pointer.first}\" container")
+
+        self.expect('frame variable mine',
+                    substrs = ['mine = ',
+                               '1', '<parent is NULL>'])
diff --git a/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/main.cpp b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/main.cpp
new file mode 100644
index 0000000..03a9f27
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/data-formatter/summary-string-onfail/main.cpp
@@ -0,0 +1,30 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+//                     The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+#include <stdio.h>
+
+struct contained
+{
+    int first;
+    int second;
+};
+
+struct container
+{
+    int scalar;
+    struct contained *pointer;
+};
+
+int main ()
+{
+    struct container mine = {1, 0};
+    printf ("Mine's scalar is the only thing that is good: %d.\n", mine.scalar); // Set break point at this line.
+    return 0;
+}
+
-- 
cgit v1.1