From 78b9749c0a4ea980a8b934645da6ae98fcc665e8 Mon Sep 17 00:00:00 2001
From: dim <dim@FreeBSD.org>
Date: Wed, 6 Jan 2016 20:12:03 +0000
Subject: Vendor import of lldb trunk r256945:
 https://llvm.org/svn/llvm-project/lldb/trunk@256945

---
 .../test/functionalities/breakpoint/objc/Makefile  |  7 ++
 .../breakpoint/objc/TestObjCBreakpoints.py         | 94 +++++++++++++++++++++
 .../test/functionalities/breakpoint/objc/main.m    | 98 ++++++++++++++++++++++
 3 files changed, 199 insertions(+)
 create mode 100644 packages/Python/lldbsuite/test/functionalities/breakpoint/objc/Makefile
 create mode 100644 packages/Python/lldbsuite/test/functionalities/breakpoint/objc/TestObjCBreakpoints.py
 create mode 100644 packages/Python/lldbsuite/test/functionalities/breakpoint/objc/main.m

(limited to 'packages/Python/lldbsuite/test/functionalities/breakpoint/objc')

diff --git a/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/Makefile b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/Makefile
new file mode 100644
index 0000000..ad3cb3f
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/Makefile
@@ -0,0 +1,7 @@
+LEVEL = ../../../make
+
+OBJC_SOURCES := main.m
+
+include $(LEVEL)/Makefile.rules
+
+LDFLAGS += -framework Foundation
diff --git a/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/TestObjCBreakpoints.py b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/TestObjCBreakpoints.py
new file mode 100644
index 0000000..648a0f5
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/TestObjCBreakpoints.py
@@ -0,0 +1,94 @@
+"""
+Test that objective-c constant strings are generated correctly by the expression
+parser.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+import shutil
+import subprocess
+
+@skipUnlessDarwin
+class TestObjCBreakpoints(TestBase):
+
+    mydir = TestBase.compute_mydir(__file__)
+
+    def test_break(self):
+        """Test setting Objective C specific breakpoints (DWARF in .o files)."""
+        self.build()
+        self.setTearDownCleanup()
+        self.check_objc_breakpoints(False)
+
+    def setUp(self):
+        # Call super's setUp().
+        TestBase.setUp(self)
+        # Find the line number to break inside main().
+        self.main_source = "main.m"
+        self.line = line_number(self.main_source, '// Set breakpoint here')
+
+    def check_category_breakpoints(self):
+        name_bp = self.target.BreakpointCreateByName ("myCategoryFunction")
+        selector_bp = self.target.BreakpointCreateByName ("myCategoryFunction", lldb.eFunctionNameTypeSelector, lldb.SBFileSpecList(), lldb.SBFileSpecList())
+        self.assertTrue(name_bp.GetNumLocations() == selector_bp.GetNumLocations(), 'Make sure setting a breakpoint by name "myCategoryFunction" sets a breakpoint even though it is in a category')
+        for bp_loc in selector_bp:
+            function_name = bp_loc.GetAddress().GetSymbol().GetName()
+            self.assertTrue(" myCategoryFunction]" in function_name, 'Make sure all function names have " myCategoryFunction]" in their names')
+            
+        category_bp = self.target.BreakpointCreateByName ("-[MyClass(MyCategory) myCategoryFunction]")
+        stripped_bp = self.target.BreakpointCreateByName ("-[MyClass myCategoryFunction]")
+        stripped2_bp = self.target.BreakpointCreateByName ("[MyClass myCategoryFunction]")
+        self.assertTrue(category_bp.GetNumLocations() == 1, "Make sure we can set a breakpoint using a full objective C function name with the category included (-[MyClass(MyCategory) myCategoryFunction])")
+        self.assertTrue(stripped_bp.GetNumLocations() == 1, "Make sure we can set a breakpoint using a full objective C function name without the category included (-[MyClass myCategoryFunction])")
+        self.assertTrue(stripped2_bp.GetNumLocations() == 1, "Make sure we can set a breakpoint using a full objective C function name without the category included ([MyClass myCategoryFunction])")
+        
+    def check_objc_breakpoints(self, have_dsym):
+        """Test constant string generation amd comparison by the expression parser."""
+
+        # Set debugger into synchronous mode
+        self.dbg.SetAsync(False)
+
+        # Create a target by the debugger.
+        exe = os.path.join(os.getcwd(), "a.out")
+        self.target = self.dbg.CreateTarget(exe)
+        self.assertTrue(self.target, VALID_TARGET)
+
+        #----------------------------------------------------------------------
+        # Set breakpoints on all selectors whose name is "count". This should 
+        # catch breakpoints that are both C functions _and_ anything whose 
+        # selector is "count" because just looking at "count" we can't tell
+        # definitively if the name is a selector or a C function
+        #----------------------------------------------------------------------
+        name_bp = self.target.BreakpointCreateByName ("count")
+        selector_bp = self.target.BreakpointCreateByName ("count", lldb.eFunctionNameTypeSelector, lldb.SBFileSpecList(), lldb.SBFileSpecList())
+        self.assertTrue(name_bp.GetNumLocations() >= selector_bp.GetNumLocations(), 'Make sure we get at least the same amount of breakpoints if not more when setting by name "count"')
+        self.assertTrue(selector_bp.GetNumLocations() > 50, 'Make sure we find a lot of "count" selectors') # There are 93 on the latest MacOSX
+        for bp_loc in selector_bp:
+            function_name = bp_loc.GetAddress().GetSymbol().GetName()
+            self.assertTrue(" count]" in function_name, 'Make sure all function names have " count]" in their names')
+
+        #----------------------------------------------------------------------
+        # Set breakpoints on all selectors whose name is "isEqual:". This should
+        # catch breakpoints that are only ObjC selectors because no C function
+        # can end with a :
+        #----------------------------------------------------------------------
+        name_bp = self.target.BreakpointCreateByName ("isEqual:")
+        selector_bp = self.target.BreakpointCreateByName ("isEqual:", lldb.eFunctionNameTypeSelector, lldb.SBFileSpecList(), lldb.SBFileSpecList())
+        self.assertTrue(name_bp.GetNumLocations() == selector_bp.GetNumLocations(), 'Make sure setting a breakpoint by name "isEqual:" only sets selector breakpoints')
+        for bp_loc in selector_bp:
+            function_name = bp_loc.GetAddress().GetSymbol().GetName()
+            self.assertTrue(" isEqual:]" in function_name, 'Make sure all function names have " isEqual:]" in their names')
+    
+        self.check_category_breakpoints()
+        
+        if have_dsym:
+            shutil.rmtree(exe + ".dSYM")
+        self.assertTrue(subprocess.call(['/usr/bin/strip', '-Sx', exe]) == 0, 'stripping dylib succeeded')
+        
+        # Check breakpoints again, this time using the symbol table only
+        self.check_category_breakpoints()
diff --git a/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/main.m b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/main.m
new file mode 100644
index 0000000..5356749
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/breakpoint/objc/main.m
@@ -0,0 +1,98 @@
+#import <Foundation/Foundation.h>
+#include <unistd.h>
+
+@interface MyClass : NSObject
+@end
+
+@implementation MyClass : NSObject
+@end
+
+@implementation MyClass (MyCategory)
+
+
+- (void) myCategoryFunction {
+    NSLog (@"myCategoryFunction");
+}
+
+@end
+
+
+    
+int
+Test_Selector ()
+{
+    SEL sel = @selector(length);
+    printf("sel = %p\n", sel);
+    // Expressions to test here for selector: 
+    // expression (char *)sel_getName(sel)
+    //      The expression above should return "sel" as it should be just
+    //      a uniqued C string pointer. We were seeing the result pointer being
+    //      truncated with recent LLDBs.
+    return 0; // Break here for selector: tests
+}
+
+int
+Test_NSString (const char *program)
+{
+    NSString *str = [NSString stringWithFormat:@"Hello from '%s'", program];
+    NSLog(@"NSString instance: %@", str);
+    printf("str = '%s'\n", [str cStringUsingEncoding: [NSString defaultCStringEncoding]]);
+    printf("[str length] = %zu\n", (size_t)[str length]);
+    printf("[str description] = %s\n", [[str description] UTF8String]);
+    id str_id = str;
+    // Expressions to test here for NSString:
+    // expression (char *)sel_getName(sel)
+    // expression [str length]
+    // expression [str_id length]
+    // expression [str description]
+    // expression [str_id description]
+    // expression str.length
+    // expression str.description
+    // expression str = @"new"
+    // expression str = [NSString stringWithFormat: @"%cew", 'N']
+    return 0; // Break here for NSString tests
+}
+
+NSString *my_global_str = NULL;
+
+int
+Test_NSArray ()
+{
+    NSMutableArray *nil_mutable_array = nil;
+    NSArray *array1 = [NSArray arrayWithObjects: @"array1 object1", @"array1 object2", @"array1 object3", nil];
+    NSArray *array2 = [NSArray arrayWithObjects: array1, @"array2 object2", @"array2 object3", nil];
+    // Expressions to test here for NSArray:
+    // expression [nil_mutable_array count]
+    // expression [array1 count]
+    // expression array1.count
+    // expression [array2 count]
+    // expression array2.count
+    id obj;
+    // After each object at index call, use expression and validate object
+    obj = [array1 objectAtIndex: 0]; // Break here for NSArray tests
+    obj = [array1 objectAtIndex: 1];
+    obj = [array1 objectAtIndex: 2];
+
+    obj = [array2 objectAtIndex: 0];
+    obj = [array2 objectAtIndex: 1];
+    obj = [array2 objectAtIndex: 2];
+    NSUInteger count = [nil_mutable_array count];
+    return 0;
+}
+
+
+int main (int argc, char const *argv[])
+{
+    NSAutoreleasePool * pool = [[NSAutoreleasePool alloc] init];
+    Test_Selector(); // Set breakpoint here
+    Test_NSArray ();
+    Test_NSString (argv[0]);
+    MyClass *my_class = [[MyClass alloc] init];
+    [my_class myCategoryFunction];
+    printf("sizeof(id) = %zu\n", sizeof(id));
+    printf("sizeof(Class) = %zu\n", sizeof(Class));
+    printf("sizeof(SEL) = %zu\n", sizeof(SEL));
+
+    [pool release];
+    return 0;
+}
-- 
cgit v1.1