summaryrefslogtreecommitdiffstats
path: root/tools/libclang/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/libclang/CMakeLists.txt')
-rw-r--r--tools/libclang/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/libclang/CMakeLists.txt b/tools/libclang/CMakeLists.txt
index f1c3f4c..26f88a9 100644
--- a/tools/libclang/CMakeLists.txt
+++ b/tools/libclang/CMakeLists.txt
@@ -51,6 +51,11 @@ if (CLANG_ENABLE_ARCMT)
list(APPEND LIBS clangARCMigrate)
endif ()
+find_library(DL_LIBRARY_PATH dl)
+if (DL_LIBRARY_PATH)
+ list(APPEND LIBS dl)
+endif()
+
option(LIBCLANG_BUILD_STATIC
"Build libclang as a static library (in addition to a shared one)" OFF)
OpenPOWER on IntegriCloud