summaryrefslogtreecommitdiffstats
path: root/tools/c-index-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/c-index-test/CMakeLists.txt')
-rw-r--r--tools/c-index-test/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/c-index-test/CMakeLists.txt b/tools/c-index-test/CMakeLists.txt
index 6f28c54..d90dc6d 100644
--- a/tools/c-index-test/CMakeLists.txt
+++ b/tools/c-index-test/CMakeLists.txt
@@ -23,8 +23,7 @@ set_target_properties(c-index-test
LINKER_LANGUAGE CXX)
# If libxml2 is available, make it available for c-index-test.
-if (LIBXML2_FOUND)
- add_definitions(${LIBXML2_DEFINITIONS} "-DCLANG_HAVE_LIBXML")
+if (CLANG_HAVE_LIBXML)
include_directories(${LIBXML2_INCLUDE_DIR})
target_link_libraries(c-index-test ${LIBXML2_LIBRARIES})
endif()
OpenPOWER on IntegriCloud