summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt22
1 files changed, 3 insertions, 19 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 9668c76..1bfc2fe 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,14 +2,6 @@
# three small executables. This is done to minimize memory load in parallel
# builds. Please retain this ordering.
-# If polly exists and is not disabled compile it and add it to the LLVM tools.
-option(LLVM_BUILD_POLLY "Compile polly" ON)
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
- if (LLVM_BUILD_POLLY)
- add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/polly)
- endif (LLVM_BUILD_POLLY)
-endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
-
if( NOT WIN32 OR MSYS OR CYGWIN )
# We currently require 'sed' to build llvm-config, so don't try to build it
# on pure Win32.
@@ -27,7 +19,6 @@ add_subdirectory(llvm-ar)
add_subdirectory(llvm-nm)
add_subdirectory(llvm-size)
-add_subdirectory(llvm-ld)
add_subdirectory(llvm-cov)
add_subdirectory(llvm-prof)
add_subdirectory(llvm-link)
@@ -44,7 +35,6 @@ add_subdirectory(llvm-dwarfdump)
add_subdirectory(bugpoint)
add_subdirectory(bugpoint-passes)
add_subdirectory(llvm-bcanalyzer)
-add_subdirectory(llvm-stub)
add_subdirectory(llvm-stress)
if( NOT WIN32 )
@@ -58,14 +48,8 @@ if( LLVM_ENABLE_PIC )
endif()
endif()
-set(LLVM_CLANG_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/clang" CACHE PATH "Path to Clang source directory")
-
-if (NOT ${LLVM_CLANG_SOURCE_DIR} STREQUAL ""
- AND EXISTS ${LLVM_CLANG_SOURCE_DIR}/CMakeLists.txt)
- option(LLVM_BUILD_CLANG "Whether to build Clang as part of LLVM" ON)
- if (${LLVM_BUILD_CLANG})
- add_subdirectory(${LLVM_CLANG_SOURCE_DIR} clang)
- endif()
-endif ()
+add_llvm_external_project(clang)
+add_llvm_external_project(lld)
+add_llvm_external_project(polly)
set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} PARENT_SCOPE)
OpenPOWER on IntegriCloud