summaryrefslogtreecommitdiffstats
path: root/test/CXX/except/except.spec/p9-dynamic.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'test/CXX/except/except.spec/p9-dynamic.cpp')
-rw-r--r--test/CXX/except/except.spec/p9-dynamic.cpp11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/CXX/except/except.spec/p9-dynamic.cpp b/test/CXX/except/except.spec/p9-dynamic.cpp
new file mode 100644
index 0000000..490d2fa
--- /dev/null
+++ b/test/CXX/except/except.spec/p9-dynamic.cpp
@@ -0,0 +1,11 @@
+// RUN: %clang_cc1 %s -triple=x86_64-apple-darwin10 -emit-llvm -o - -fcxx-exceptions -fexceptions | FileCheck %s
+
+void external();
+
+void target() throw(int)
+{
+ // CHECK: invoke void @_Z8externalv()
+ external();
+}
+// CHECK: call i32 (i8*, i8*, ...)* @llvm.eh.selector({{.*}} i8* bitcast (i8** @_ZTIi to i8*), i8* null) nounwind
+// CHECK: call void @__cxa_call_unexpected
OpenPOWER on IntegriCloud