summaryrefslogtreecommitdiffstats
path: root/test/CXX/except/except.spec/p1.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'test/CXX/except/except.spec/p1.cpp')
-rw-r--r--test/CXX/except/except.spec/p1.cpp13
1 files changed, 13 insertions, 0 deletions
diff --git a/test/CXX/except/except.spec/p1.cpp b/test/CXX/except/except.spec/p1.cpp
index 0559285..86924bb 100644
--- a/test/CXX/except/except.spec/p1.cpp
+++ b/test/CXX/except/except.spec/p1.cpp
@@ -58,3 +58,16 @@ namespace noex {
void g2(bool b) noexcept(b); // expected-error {{argument to noexcept specifier must be a constant expression}}
}
+
+namespace noexcept_unevaluated {
+ template<typename T> void f(T) {
+ T* x = 1;
+ }
+
+ template<typename T>
+ void g(T x) noexcept((f(x), sizeof(T) == 4)) { }
+
+ void h() {
+ g(1);
+ }
+}
OpenPOWER on IntegriCloud