summaryrefslogtreecommitdiffstats
path: root/scripts/Python/modules/readline/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Python/modules/readline/CMakeLists.txt')
-rw-r--r--scripts/Python/modules/readline/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/scripts/Python/modules/readline/CMakeLists.txt b/scripts/Python/modules/readline/CMakeLists.txt
new file mode 100644
index 0000000..0a4376c
--- /dev/null
+++ b/scripts/Python/modules/readline/CMakeLists.txt
@@ -0,0 +1,25 @@
+# FIXME: if a non-standard version of python is requested, the cmake macro
+# below will need Python_ADDITIONAL_VERSIONS set in order to find it.
+include(FindPythonInterp)
+SET(PYTHON_DIRECTORY python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+
+# Build the readline python module
+include_directories(${PYTHON_INCLUDE_DIR})
+add_library(readline SHARED readline.cpp)
+
+if (NOT LLDB_DISABLE_LIBEDIT)
+ target_link_libraries(readline ${PYTHON_LIBRARY} edit)
+else()
+ target_link_libraries(readline ${PYTHON_LIBRARY})
+endif()
+
+# FIXME: the LIBRARY_OUTPUT_PATH seems to be ignored - this is not a
+# functional issue for the build dir, though, since the shared lib dir
+# for the build is in the python shared library load path, and thus
+# python finds it when loading the python readline module.
+set_target_properties(readline PROPERTIES
+ PREFIX ""
+ LIBRARY_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR}/lib${LLVM_LIBDIR_SUFFIX}/${PYTHON_DIRECTORY})
+
+# Install the readline module.
+install(TARGETS readline LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib${LLVM_LIBDIR_SUFFIX}/${PYTHON_DIRECTORY})
OpenPOWER on IntegriCloud