summaryrefslogtreecommitdiffstats
path: root/ntpq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ntpq/Makefile.am')
-rw-r--r--ntpq/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/ntpq/Makefile.am b/ntpq/Makefile.am
new file mode 100644
index 0000000..0bd05fc
--- /dev/null
+++ b/ntpq/Makefile.am
@@ -0,0 +1,21 @@
+#AUTOMAKE_OPTIONS = ../util/ansi2knr no-dependencies
+AUTOMAKE_OPTIONS = ../util/ansi2knr
+bin_PROGRAMS = ntpq
+INCLUDES = -I$(top_srcdir)/include
+# LDADD might need RESLIB and ADJLIB
+ntpq_LDADD = version.o ../libntp/libntp.a @READLINE_LIBS@
+DISTCLEANFILES = .version version.c
+noinst_HEADERS = ntpq.h
+#EXTRA_DIST = ntpq.mak
+ETAGS_ARGS = Makefile.am
+
+ntpq_SOURCES = ntpq.c ntpq_ops.c
+
+$(PROGRAMS): $(LDADD)
+
+../libntp/libntp.a:
+ cd ../libntp && $(MAKE)
+
+version.o: $(ntpq_OBJECTS) ../libntp/libntp.a Makefile $(top_srcdir)/version
+ env CSET=`cat $(top_srcdir)/version` $(top_builddir)/scripts/mkver ntpq
+ $(COMPILE) -c version.c
OpenPOWER on IntegriCloud