summaryrefslogtreecommitdiffstats
path: root/lib/Transforms/Scalar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/Scalar/CMakeLists.txt')
-rw-r--r--lib/Transforms/Scalar/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/Transforms/Scalar/CMakeLists.txt b/lib/Transforms/Scalar/CMakeLists.txt
index b7598ea..106fb8f 100644
--- a/lib/Transforms/Scalar/CMakeLists.txt
+++ b/lib/Transforms/Scalar/CMakeLists.txt
@@ -6,13 +6,15 @@ add_llvm_library(LLVMScalarOpts
CorrelatedValuePropagation.cpp
DCE.cpp
DeadStoreElimination.cpp
+ EarlyCSE.cpp
GEPSplitter.cpp
GVN.cpp
IndVarSimplify.cpp
JumpThreading.cpp
LICM.cpp
LoopDeletion.cpp
- LoopIndexSplit.cpp
+ LoopIdiomRecognize.cpp
+ LoopInstSimplify.cpp
LoopRotation.cpp
LoopStrengthReduce.cpp
LoopUnrollPass.cpp
@@ -31,5 +33,3 @@ add_llvm_library(LLVMScalarOpts
TailDuplication.cpp
TailRecursionElimination.cpp
)
-
-target_link_libraries (LLVMScalarOpts LLVMTransformUtils)
OpenPOWER on IntegriCloud