summaryrefslogtreecommitdiffstats
path: root/lib/Transforms/Scalar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/Scalar/CMakeLists.txt')
-rw-r--r--lib/Transforms/Scalar/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/Transforms/Scalar/CMakeLists.txt b/lib/Transforms/Scalar/CMakeLists.txt
index cbeed4c..e048518 100644
--- a/lib/Transforms/Scalar/CMakeLists.txt
+++ b/lib/Transforms/Scalar/CMakeLists.txt
@@ -1,12 +1,13 @@
add_llvm_library(LLVMScalarOpts
+ ABCD.cpp
ADCE.cpp
BasicBlockPlacement.cpp
- CodeGenLICM.cpp
CodeGenPrepare.cpp
CondPropagate.cpp
ConstantProp.cpp
DCE.cpp
DeadStoreElimination.cpp
+ GEPSplitter.cpp
GVN.cpp
IndVarSimplify.cpp
InstructionCombining.cpp
@@ -16,12 +17,13 @@ add_llvm_library(LLVMScalarOpts
LoopIndexSplit.cpp
LoopRotation.cpp
LoopStrengthReduce.cpp
- LoopUnroll.cpp
+ LoopUnrollPass.cpp
LoopUnswitch.cpp
MemCpyOptimizer.cpp
Reassociate.cpp
Reg2Mem.cpp
SCCP.cpp
+ SCCVN.cpp
Scalar.cpp
ScalarReplAggregates.cpp
SimplifyCFGPass.cpp
OpenPOWER on IntegriCloud