summaryrefslogtreecommitdiffstats
path: root/lib/Transforms/IPO/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/IPO/CMakeLists.txt')
-rw-r--r--lib/Transforms/IPO/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/Transforms/IPO/CMakeLists.txt b/lib/Transforms/IPO/CMakeLists.txt
index 1438b48..ec0f1e1 100644
--- a/lib/Transforms/IPO/CMakeLists.txt
+++ b/lib/Transforms/IPO/CMakeLists.txt
@@ -1,18 +1,19 @@
add_llvm_library(LLVMipo
- FunctionAttrs.cpp
ArgumentPromotion.cpp
ConstantMerge.cpp
DeadArgumentElimination.cpp
DeadTypeElimination.cpp
ExtractGV.cpp
+ FunctionAttrs.cpp
GlobalDCE.cpp
GlobalOpt.cpp
+ IPConstantPropagation.cpp
+ IPO.cpp
IndMemRemoval.cpp
InlineAlways.cpp
- Inliner.cpp
InlineSimple.cpp
+ Inliner.cpp
Internalize.cpp
- IPConstantPropagation.cpp
LoopExtractor.cpp
LowerSetJmp.cpp
MergeFunctions.cpp
OpenPOWER on IntegriCloud