summaryrefslogtreecommitdiffstats
path: root/lib/Target/SystemZ/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/SystemZ/CMakeLists.txt')
-rw-r--r--lib/Target/SystemZ/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/Target/SystemZ/CMakeLists.txt b/lib/Target/SystemZ/CMakeLists.txt
index 880e56f..1f5d355 100644
--- a/lib/Target/SystemZ/CMakeLists.txt
+++ b/lib/Target/SystemZ/CMakeLists.txt
@@ -11,9 +11,11 @@ tablegen(SystemZGenCallingConv.inc -gen-callingconv)
tablegen(SystemZGenSubtarget.inc -gen-subtarget)
add_llvm_target(SystemZCodeGen
+ SystemZAsmPrinter.cpp
SystemZISelDAGToDAG.cpp
SystemZISelLowering.cpp
SystemZInstrInfo.cpp
+ SystemZFrameLowering.cpp
SystemZMCAsmInfo.cpp
SystemZRegisterInfo.cpp
SystemZSubtarget.cpp
@@ -21,4 +23,4 @@ add_llvm_target(SystemZCodeGen
SystemZSelectionDAGInfo.cpp
)
-target_link_libraries (LLVMSystemZCodeGen LLVMSelectionDAG)
+add_subdirectory(TargetInfo)
OpenPOWER on IntegriCloud