summaryrefslogtreecommitdiffstats
path: root/lib/Target/MSP430/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/MSP430/CMakeLists.txt')
-rw-r--r--lib/Target/MSP430/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/Target/MSP430/CMakeLists.txt b/lib/Target/MSP430/CMakeLists.txt
index a3f60d2..2c7cbb6 100644
--- a/lib/Target/MSP430/CMakeLists.txt
+++ b/lib/Target/MSP430/CMakeLists.txt
@@ -15,11 +15,15 @@ add_llvm_target(MSP430CodeGen
MSP430ISelDAGToDAG.cpp
MSP430ISelLowering.cpp
MSP430InstrInfo.cpp
+ MSP430FrameLowering.cpp
MSP430MCAsmInfo.cpp
MSP430RegisterInfo.cpp
MSP430Subtarget.cpp
MSP430TargetMachine.cpp
MSP430SelectionDAGInfo.cpp
+ MSP430AsmPrinter.cpp
+ MSP430MCInstLower.cpp
)
-target_link_libraries (LLVMMSP430CodeGen LLVMSelectionDAG)
+add_subdirectory(InstPrinter)
+add_subdirectory(TargetInfo)
OpenPOWER on IntegriCloud