summaryrefslogtreecommitdiffstats
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
index f982316..030f808 100644
--- a/lib/Target/CMakeLists.txt
+++ b/lib/Target/CMakeLists.txt
@@ -1,8 +1,6 @@
add_llvm_library(LLVMTarget
Mangler.cpp
Target.cpp
- TargetAsmInfo.cpp
- TargetAsmLexer.cpp
TargetData.cpp
TargetELFWriterInfo.cpp
TargetFrameLowering.cpp
@@ -15,6 +13,12 @@ add_llvm_library(LLVMTarget
TargetSubtargetInfo.cpp
)
+add_llvm_library_dependencies(LLVMTarget
+ LLVMCore
+ LLVMMC
+ LLVMSupport
+ )
+
set(LLVM_ENUM_ASM_PRINTERS "")
set(LLVM_ENUM_ASM_PARSERS "")
set(LLVM_ENUM_DISASSEMBLERS "")
OpenPOWER on IntegriCloud