summaryrefslogtreecommitdiffstats
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt58
1 files changed, 56 insertions, 2 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index 0c70a40..a0e997d 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -1,3 +1,9 @@
+## FIXME: This only requires RTTI because tblgen uses it. Fix that.
+set(LLVM_REQUIRES_RTTI 1)
+if( MINGW )
+ set(LLVM_REQUIRES_EH 1)
+endif()
+
add_llvm_library(LLVMSupport
APFloat.cpp
APInt.cpp
@@ -16,6 +22,8 @@ add_llvm_library(LLVMSupport
FoldingSet.cpp
FormattedStream.cpp
GraphWriter.cpp
+ IntEqClasses.cpp
+ IntervalMap.cpp
IsInf.cpp
IsNAN.cpp
ManagedStatic.cpp
@@ -35,6 +43,7 @@ add_llvm_library(LLVMSupport
SystemUtils.cpp
TargetRegistry.cpp
Timer.cpp
+ ToolOutputFile.cpp
Triple.cpp
Twine.cpp
raw_os_ostream.cpp
@@ -44,6 +53,51 @@ add_llvm_library(LLVMSupport
regexec.c
regfree.c
regstrlcpy.c
- )
-target_link_libraries (LLVMSupport LLVMSystem)
+# System
+ Atomic.cpp
+ Disassembler.cpp
+ DynamicLibrary.cpp
+ Errno.cpp
+ Host.cpp
+ IncludeFile.cpp
+ Memory.cpp
+ Mutex.cpp
+ Path.cpp
+ PathV2.cpp
+ Process.cpp
+ Program.cpp
+ RWMutex.cpp
+ SearchForAddressOfSpecialSymbol.cpp
+ Signals.cpp
+ system_error.cpp
+ ThreadLocal.cpp
+ Threading.cpp
+ TimeValue.cpp
+ Valgrind.cpp
+ Unix/Host.inc
+ Unix/Memory.inc
+ Unix/Mutex.inc
+ Unix/Path.inc
+ Unix/PathV2.inc
+ Unix/Process.inc
+ Unix/Program.inc
+ Unix/RWMutex.inc
+ Unix/Signals.inc
+ Unix/system_error.inc
+ Unix/ThreadLocal.inc
+ Unix/TimeValue.inc
+ Windows/DynamicLibrary.inc
+ Windows/Host.inc
+ Windows/Memory.inc
+ Windows/Mutex.inc
+ Windows/Path.inc
+ Windows/PathV2.inc
+ Windows/Process.inc
+ Windows/Program.inc
+ Windows/RWMutex.inc
+ Windows/Signals.inc
+ Windows/system_error.inc
+ Windows/ThreadLocal.inc
+ Windows/TimeValue.inc
+ )
OpenPOWER on IntegriCloud