summaryrefslogtreecommitdiffstats
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index f26c2c0..cd355ff 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -3,32 +3,43 @@ add_llvm_library(LLVMSupport
APInt.cpp
APSInt.cpp
Allocator.cpp
- Annotation.cpp
CommandLine.cpp
ConstantRange.cpp
Debug.cpp
Dwarf.cpp
+ ErrorHandling.cpp
FileUtilities.cpp
FoldingSet.cpp
+ FormattedStream.cpp
GraphWriter.cpp
IsInf.cpp
IsNAN.cpp
ManagedStatic.cpp
MemoryBuffer.cpp
+ MemoryObject.cpp
PluginLoader.cpp
PrettyStackTrace.cpp
+ Regex.cpp
SlowOperationInformer.cpp
SmallPtrSet.cpp
SourceMgr.cpp
Statistic.cpp
- Streams.cpp
StringExtras.cpp
StringMap.cpp
StringPool.cpp
+ StringRef.cpp
SystemUtils.cpp
+ TargetRegistry.cpp
Timer.cpp
Triple.cpp
+ Twine.cpp
+ raw_os_ostream.cpp
raw_ostream.cpp
+ regcomp.c
+ regerror.c
+ regexec.c
+ regfree.c
+ regstrlcpy.c
)
target_link_libraries (LLVMSupport LLVMSystem)
OpenPOWER on IntegriCloud