summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
new file mode 100644
index 0000000..321dac1
--- /dev/null
+++ b/lib/Sema/CMakeLists.txt
@@ -0,0 +1,33 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangSema
+ IdentifierResolver.cpp
+ JumpDiagnostics.cpp
+ ParseAST.cpp
+ Sema.cpp
+ SemaAccess.cpp
+ SemaAttr.cpp
+ SemaChecking.cpp
+ SemaCXXScopeSpec.cpp
+ SemaDeclAttr.cpp
+ SemaDecl.cpp
+ SemaDeclCXX.cpp
+ SemaDeclObjC.cpp
+ SemaExpr.cpp
+ SemaExprCXX.cpp
+ SemaExprObjC.cpp
+ SemaInherit.cpp
+ SemaInit.cpp
+ SemaLookup.cpp
+ SemaNamedCast.cpp
+ SemaOverload.cpp
+ SemaStmt.cpp
+ SemaTemplate.cpp
+ SemaTemplateInstantiate.cpp
+ SemaTemplateInstantiateDecl.cpp
+ SemaTemplateInstantiateExpr.cpp
+ SemaTemplateInstantiateStmt.cpp
+ SemaType.cpp
+ )
+
+add_dependencies(clangSema ClangDiagnosticSema)
OpenPOWER on IntegriCloud