summaryrefslogtreecommitdiffstats
path: root/lib/Lex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Lex/CMakeLists.txt')
-rw-r--r--lib/Lex/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/lib/Lex/CMakeLists.txt b/lib/Lex/CMakeLists.txt
index 0a2ffdb..241abbc 100644
--- a/lib/Lex/CMakeLists.txt
+++ b/lib/Lex/CMakeLists.txt
@@ -2,8 +2,6 @@
set(LLVM_LINK_COMPONENTS support)
-set(LLVM_USED_LIBS clangBasic)
-
add_clang_library(clangLex
HeaderMap.cpp
HeaderSearch.cpp
@@ -28,4 +26,12 @@ add_clang_library(clangLex
TokenLexer.cpp
)
-add_dependencies(clangLex ClangDiagnosticLex ClangAttrSpellings)
+add_dependencies(clangLex
+ ClangAttrSpellings
+ ClangDiagnosticCommon
+ ClangDiagnosticLex
+ )
+
+target_link_libraries(clangLex
+ clangBasic
+ )
OpenPOWER on IntegriCloud