summaryrefslogtreecommitdiffstats
path: root/lib/Lex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Lex/CMakeLists.txt')
-rw-r--r--lib/Lex/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/lib/Lex/CMakeLists.txt b/lib/Lex/CMakeLists.txt
index 632fbc6..80e2820 100644
--- a/lib/Lex/CMakeLists.txt
+++ b/lib/Lex/CMakeLists.txt
@@ -1,7 +1,9 @@
-set(LLVM_NO_RTTI 1)
-
# TODO: Add -maltivec when ARCH is PowerPC.
+set(LLVM_LINK_COMPONENTS support)
+
+set(LLVM_USED_LIBS clangBasic)
+
add_clang_library(clangLex
HeaderMap.cpp
HeaderSearch.cpp
@@ -24,4 +26,4 @@ add_clang_library(clangLex
TokenLexer.cpp
)
-add_dependencies(clangLex ClangDiagnosticLex)
+add_dependencies(clangLex ClangDiagnosticLex ClangAttrSpellings)
OpenPOWER on IntegriCloud