summaryrefslogtreecommitdiffstats
path: root/lib/Frontend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Frontend/CMakeLists.txt')
-rw-r--r--lib/Frontend/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/Frontend/CMakeLists.txt b/lib/Frontend/CMakeLists.txt
index 39128fb..2bee240 100644
--- a/lib/Frontend/CMakeLists.txt
+++ b/lib/Frontend/CMakeLists.txt
@@ -2,6 +2,7 @@ set( LLVM_USED_LIBS
clangAST
clangBasic
clangDriver
+ clangEdit
clangLex
clangParse
clangSema
@@ -13,10 +14,14 @@ add_clang_library(clangFrontend
ASTMerge.cpp
ASTUnit.cpp
CacheTokens.cpp
+ ChainedDiagnosticConsumer.cpp
+ ChainedIncludesSource.cpp
CompilerInstance.cpp
CompilerInvocation.cpp
CreateInvocationFromCommandLine.cpp
DependencyFile.cpp
+ DependencyGraph.cpp
+ DiagnosticRenderer.cpp
FrontendAction.cpp
FrontendActions.cpp
FrontendOptions.cpp
@@ -24,9 +29,12 @@ add_clang_library(clangFrontend
InitHeaderSearch.cpp
InitPreprocessor.cpp
LangStandards.cpp
+ LayoutOverrideSource.cpp
LogDiagnosticPrinter.cpp
MultiplexConsumer.cpp
PrintPreprocessedOutput.cpp
+ SerializedDiagnosticPrinter.cpp
+ TextDiagnostic.cpp
TextDiagnosticBuffer.cpp
TextDiagnosticPrinter.cpp
VerifyDiagnosticConsumer.cpp
OpenPOWER on IntegriCloud