summaryrefslogtreecommitdiffstats
path: root/lib/Format/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Format/CMakeLists.txt')
-rw-r--r--lib/Format/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/Format/CMakeLists.txt b/lib/Format/CMakeLists.txt
new file mode 100644
index 0000000..d8630ee
--- /dev/null
+++ b/lib/Format/CMakeLists.txt
@@ -0,0 +1,26 @@
+set(LLVM_LINK_COMPONENTS support)
+
+add_clang_library(clangFormat
+ TokenAnnotator.cpp
+ UnwrappedLineParser.cpp
+ Format.cpp
+ )
+
+add_dependencies(clangFormat
+ ClangAttrClasses
+ ClangAttrList
+ ClangDeclNodes
+ ClangDiagnosticCommon
+ ClangDiagnosticFrontend
+ ClangStmtNodes
+ )
+
+target_link_libraries(clangFormat
+ clangBasic
+ clangFrontend
+ clangAST
+ clangASTMatchers
+ clangRewriteCore
+ clangRewriteFrontend
+ clangTooling
+ )
OpenPOWER on IntegriCloud