summaryrefslogtreecommitdiffstats
path: root/lib/ExecutionEngine/Interpreter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ExecutionEngine/Interpreter/CMakeLists.txt')
-rw-r--r--lib/ExecutionEngine/Interpreter/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/ExecutionEngine/Interpreter/CMakeLists.txt b/lib/ExecutionEngine/Interpreter/CMakeLists.txt
index dff97fa..d331f83 100644
--- a/lib/ExecutionEngine/Interpreter/CMakeLists.txt
+++ b/lib/ExecutionEngine/Interpreter/CMakeLists.txt
@@ -1,5 +1,17 @@
+# Make sure that the path to libffi headers is on the command
+# line. That path can be a compiler's non-default path even when
+# FFI_INCLUDE_DIR was not used, because cmake has its own paths for
+# searching for headers (CMAKE_SYSTEM_INCLUDE_PATH, for instance):
+if( FFI_INCLUDE_PATH )
+ include_directories( ${FFI_INCLUDE_PATH} )
+endif()
+
add_llvm_library(LLVMInterpreter
Execution.cpp
ExternalFunctions.cpp
Interpreter.cpp
)
+
+if( LLVM_ENABLE_FFI )
+ target_link_libraries( LLVMInterpreter ${FFI_LIBRARY_PATH} )
+endif()
OpenPOWER on IntegriCloud