summaryrefslogtreecommitdiffstats
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
new file mode 100644
index 0000000..9e8248f
--- /dev/null
+++ b/lib/Analysis/CMakeLists.txt
@@ -0,0 +1,36 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangAnalysis
+ BasicConstraintManager.cpp
+ BasicObjCFoundationChecks.cpp
+ BasicStore.cpp
+ BasicValueFactory.cpp
+ BugReporter.cpp
+ CFRefCount.cpp
+ CheckDeadStores.cpp
+ CheckNSError.cpp
+ CheckObjCDealloc.cpp
+ CheckObjCInstMethSignature.cpp
+ CheckObjCUnusedIVars.cpp
+ Environment.cpp
+ ExplodedGraph.cpp
+ GRBlockCounter.cpp
+ GRCoreEngine.cpp
+ GRExprEngine.cpp
+ GRExprEngineInternalChecks.cpp
+ GRSimpleVals.cpp
+ GRState.cpp
+ GRTransferFuncs.cpp
+ LiveVariables.cpp
+ MemRegion.cpp
+ PathDiagnostic.cpp
+ RangeConstraintManager.cpp
+ RegionStore.cpp
+ SimpleConstraintManager.cpp
+ Store.cpp
+ SVals.cpp
+ SymbolManager.cpp
+ UninitializedValues.cpp
+ )
+
+add_dependencies(clangAnalysis ClangDiagnosticAnalysis)
OpenPOWER on IntegriCloud