summaryrefslogtreecommitdiffstats
path: root/lib/ASTMatchers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ASTMatchers/CMakeLists.txt')
-rw-r--r--lib/ASTMatchers/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/ASTMatchers/CMakeLists.txt b/lib/ASTMatchers/CMakeLists.txt
new file mode 100644
index 0000000..8fc7d4b
--- /dev/null
+++ b/lib/ASTMatchers/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(LLVM_LINK_COMPONENTS support)
+set(LLVM_USED_LIBS clangBasic clangAST)
+
+add_clang_library(clangASTMatchers
+ ASTMatchFinder.cpp
+ ASTMatchersInternal.cpp
+ )
+
+add_dependencies(clangASTMatchers
+ ClangAttrClasses
+ ClangAttrImpl
+ ClangAttrList
+ ClangCommentNodes
+ ClangDeclNodes
+ ClangDiagnosticCommon
+ ClangStmtNodes
+ )
OpenPOWER on IntegriCloud