summaryrefslogtreecommitdiffstats
path: root/examples/analyzer-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/analyzer-plugin/CMakeLists.txt')
-rw-r--r--examples/analyzer-plugin/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/examples/analyzer-plugin/CMakeLists.txt b/examples/analyzer-plugin/CMakeLists.txt
index 2b9d825..ba73030 100644
--- a/examples/analyzer-plugin/CMakeLists.txt
+++ b/examples/analyzer-plugin/CMakeLists.txt
@@ -1,13 +1,22 @@
set(MODULE TRUE)
-set( LLVM_USED_LIBS
- clangStaticAnalyzerCore
- )
-
set( LLVM_LINK_COMPONENTS support mc)
add_clang_library(SampleAnalyzerPlugin MainCallChecker.cpp)
+add_dependencies(SampleAnalyzerPlugin
+ ClangAttrClasses
+ ClangAttrList
+ ClangCommentNodes
+ ClangDeclNodes
+ ClangDiagnosticCommon
+ ClangStmtNodes
+ )
+
+target_link_libraries(SampleAnalyzerPlugin
+ clangStaticAnalyzerCore
+ )
+
set_target_properties(SampleAnalyzerPlugin
PROPERTIES
LINKER_LANGUAGE CXX
OpenPOWER on IntegriCloud