summaryrefslogtreecommitdiffstats
path: root/examples/PrintFunctionNames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/PrintFunctionNames/CMakeLists.txt')
-rw-r--r--examples/PrintFunctionNames/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/examples/PrintFunctionNames/CMakeLists.txt b/examples/PrintFunctionNames/CMakeLists.txt
index 86793ce..ba6a350 100644
--- a/examples/PrintFunctionNames/CMakeLists.txt
+++ b/examples/PrintFunctionNames/CMakeLists.txt
@@ -1,14 +1,23 @@
set(MODULE TRUE)
-set( LLVM_USED_LIBS
- clangFrontend
- clangAST
- )
-
set( LLVM_LINK_COMPONENTS support mc)
add_clang_library(PrintFunctionNames PrintFunctionNames.cpp)
+add_dependencies(PrintFunctionNames
+ ClangAttrClasses
+ ClangAttrList
+ ClangCommentNodes
+ ClangDeclNodes
+ ClangDiagnosticCommon
+ ClangStmtNodes
+ )
+
+target_link_libraries(PrintFunctionNames
+ clangFrontend
+ clangAST
+ )
+
set_target_properties(PrintFunctionNames
PROPERTIES
LINKER_LANGUAGE CXX
OpenPOWER on IntegriCloud