summaryrefslogtreecommitdiffstats
path: root/crypto/kerberosIV/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/kerberosIV/configure.in')
-rw-r--r--crypto/kerberosIV/configure.in61
1 files changed, 31 insertions, 30 deletions
diff --git a/crypto/kerberosIV/configure.in b/crypto/kerberosIV/configure.in
index cd2a70e..ed1bfa4 100644
--- a/crypto/kerberosIV/configure.in
+++ b/crypto/kerberosIV/configure.in
@@ -8,7 +8,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_REVISION($Revision: 1.432.2.2 $)
+AC_REVISION($Revision: 1.432.2.14 $)
AC_INIT(lib/krb/getrealm.c)
AC_CONFIG_HEADER(include/config.h)
@@ -18,7 +18,7 @@ dnl
PACKAGE=krb4
AC_SUBST(PACKAGE)dnl
-VERSION=1.0
+VERSION=1.0.5
AC_SUBST(VERSION)dnl
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Name of package])dnl
AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [Version number of package])dnl
@@ -40,6 +40,9 @@ case "$host" in
*-*-solaris2.7)
sunos=57
;;
+*-*-solaris2.8)
+ sunos=58
+ ;;
*-*-solaris2*)
sunos=50
;;
@@ -232,9 +235,7 @@ test "$AFSWS" = "yes" && AFSWS=/usr/afsws
AC_SUBST(AFSWS)
AC_ARG_ENABLE(rxkad,
-[ --enable-rxkad build rxkad library],,[
-test -f $AFSWS/include/rx/rx.h && enable_rxkad=yes
-])
+[ --enable-rxkad build rxkad library])
if test "$afs_support" = yes -a "$enable_rxkad" = yes; then
LIB_SUBDIRS="$LIB_SUBDIRS rxkad"
@@ -333,6 +334,9 @@ if test -f /lib/pse.exp ;then
LIBS="$LIBS -Wl,-bnolibpath -Wl,-bI:/lib/pse.exp"
fi
;;
+*-*-aix*)
+ LIBS="$LIBS -Wl,-bnolibpath"
+ ;;
esac
dnl
@@ -357,6 +361,7 @@ AC_CHECK_HEADERS([arpa/ftp.h \
errno.h \
fcntl.h \
fnmatch.h \
+ gdbm/ndbm.h \
grp.h \
inttypes.h \
io.h \
@@ -523,12 +528,15 @@ dnl
KRB_CHECK_X
if test "$no_x" = "yes" ; then
MAKE_X_PROGS_BIN=""
+ MAKE_X_SCRIPTS_BIN=""
MAKE_X_PROGS_LIBEXEC=""
else
MAKE_X_PROGS_BIN='$(X_PROGS_BIN)'
+ MAKE_X_SCRIPTS_BIN='$(X_SCRIPTS_BIN)'
MAKE_X_PROGS_LIBEXEC='$(X_PROGS_LIBEXEC)'
fi
AC_SUBST(MAKE_X_PROGS_BIN)dnl
+AC_SUBST(MAKE_X_SCRIPTS_BIN)dnl
AC_SUBST(MAKE_X_PROGS_LIBEXEC)dnl
AC_CHECK_XAU
@@ -772,22 +780,6 @@ AC_MSG_RESULT($LIB_AUTH_SUBDIRS)
AC_SUBST(LIB_AUTH_SUBDIRS)dnl
dnl
-dnl Figure out if we have tunnels
-dnl
-
-AC_MSG_CHECKING(for tunnel devices)
-
-APPL_KIP_DIR=
-
-if test "$ac_cv_header_net_if_tun_h" = "yes"; then
- APPL_KIP_DIR=kip
-fi
-
-AC_MSG_RESULT($ac_cv_header_net_if_tun_h)
-
-AC_SUBST(APPL_KIP_DIR)dnl
-
-dnl
dnl Checks for prototypes and declarations
dnl
@@ -996,6 +988,8 @@ timezone)
AC_HAVE_TYPE([sa_family_t],[#include <sys/socket.h>])
+AC_HAVE_TYPE([socklen_t],[#include <sys/socket.h>])
+
AC_HAVE_TYPE([struct sockaddr_storage], [#include <sys/socket.h>])
AC_KRB_STRUCT_SPWD
@@ -1022,6 +1016,8 @@ AC_CHECK_TYPE_EXTRA(ssize_t, int, [
#include <unistd.h>
#endif])
+AC_CHECK_TYPE_EXTRA(sig_atomic_t, int, [#include <signal.h>])
+
dnl
dnl Check for broken ultrix sys/socket.h
dnl
@@ -1074,22 +1070,27 @@ dnl
dnl you can link with getmsg on AIX 3.2 but you cannot run the program
dnl
-AC_CHECK_FUNCS(getmsg)
+AC_CHECK_FUNC(getmsg)
-if test "$ac_cf_func_getmsg" = "yes"; then
+if test "$ac_cv_func_getmsg" = "yes"; then
-AC_CACHE_CHECK(for working getmsg, ac_cv_func_getmsg,
+AC_CACHE_CHECK(for working getmsg, ac_cv_func_getmsg_work,
AC_TRY_RUN(
[
#include <stdio.h>
+#include <errno.h>
int main()
{
- getmsg(open("/dev/null", 0), NULL, NULL, NULL);
+ int ret;
+ ret = getmsg(open("/dev/null", 0), NULL, NULL, NULL);
+ if(ret < 0 && errno == ENOSYS)
+ return 1;
return 0;
}
-], ac_cv_func_getmsg=yes, ac_cv_func_getmsg=no, ac_cv_func_getmsg=no))
-test "$ac_cv_func_getmsg" = "yes" &&
+], ac_cv_func_getmsg_work=yes, ac_cv_func_getmsg_work=no,
+ac_cv_func_getmsg_work=no))
+test "$ac_cv_func_getmsg_work" = "yes" &&
AC_DEFINE(HAVE_GETMSG, 1, [Define if you have a working getmsg.])
fi
@@ -1154,7 +1155,7 @@ AC_DEFINE(OLD_ENVIRON)dnl
AC_MSG_CHECKING(for streamspty)
case "`uname -sr`" in
-SunOS\ 4*|OSF1*|IRIX\ 4*|HP-UX\ ?.10.*)
+SunOS\ 4*|OSF1*|IRIX\ 4*|HP-UX\ ?.1[[01]].*)
krb_cv_sys_streamspty=no
;;
AIX*)
@@ -1162,11 +1163,11 @@ AIX*)
if expr "$os_rel" : "3*" >/dev/null 2>&1; then
krb_cv_sys_streamspty=no
else
- krb_cv_sys_streamspty="$ac_cv_func_getmsg"
+ krb_cv_sys_streamspty="$ac_cv_func_getmsg_work"
fi
;;
*)
- krb_cv_sys_streamspty="$ac_cv_func_getmsg"
+ krb_cv_sys_streamspty="$ac_cv_func_getmsg_work"
;;
esac
if test "$krb_cv_sys_streamspty" = yes; then
OpenPOWER on IntegriCloud