summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/heimdal/tools/Makefile.am')
-rw-r--r--crypto/heimdal/tools/Makefile.am59
1 files changed, 43 insertions, 16 deletions
diff --git a/crypto/heimdal/tools/Makefile.am b/crypto/heimdal/tools/Makefile.am
index b7a9d24..db60f48 100644
--- a/crypto/heimdal/tools/Makefile.am
+++ b/crypto/heimdal/tools/Makefile.am
@@ -1,26 +1,53 @@
-# $Id: Makefile.am,v 1.6 2002/09/09 22:29:26 joda Exp $
+# $Id: Makefile.am 22413 2008-01-12 05:58:14Z lha $
include $(top_srcdir)/Makefile.am.common
-EXTRA_DIST = krb5-config.1
+bin_SCRIPTS = krb5-config
-CLEANFILES = krb5-config
+pkgconfigdir = $(libdir)/pkgconfig
-bin_SCRIPTS = krb5-config
+pkgconfig_DATA = heimdal-gssapi.pc
man_MANS = krb5-config.1
+if PKINIT
+LIB_pkinit = -lhx509
+endif
+
+subst = sed -e "s!@PACKAGE\@!$(PACKAGE)!g" \
+ -e "s!@VERSION\@!$(VERSION)!g" \
+ -e "s!@prefix\@!$(prefix)!g" \
+ -e "s!@exec_prefix\@!$(exec_prefix)!g" \
+ -e "s!@libdir\@!$(libdir)!g" \
+ -e "s!@includedir\@!$(includedir)!g" \
+ -e "s!@LIB_crypt\@!$(LIB_crypt)!g" \
+ -e "s!@LIB_dbopen\@!$(LIB_dbopen)!g" \
+ -e "s!@INCLUDE_hcrypto\@!$(INCLUDE_hcrypto)!g" \
+ -e "s!@LIB_hcrypto_appl\@!$(LIB_hcrypto_appl)!g" \
+ -e "s!@LIB_dlopen\@!$(LIB_dlopen)!g" \
+ -e "s!@LIB_door_create\@!$(LIB_door_create)!g" \
+ -e "s!@LIB_pkinit\@!$(LIB_pkinit)!g" \
+ -e "s!@LIBS\@!$(LIBS)!g"
+
krb5-config: krb5-config.in
- sed -e "s,@PACKAGE\@,$(PACKAGE),g" \
- -e "s,@VERSION\@,$(VERSION),g" \
- -e "s,@prefix\@,$(prefix),g" \
- -e "s,@exec_prefix\@,$(exec_prefix),g" \
- -e "s,@libdir\@,$(libdir),g" \
- -e "s,@includedir\@,$(includedir),g" \
- -e "s,@LIB_crypt\@,$(LIB_crypt),g" \
- -e "s,@LIB_dbopen\@,$(LIB_dbopen),g" \
- -e "s,@INCLUDE_des\@,$(INCLUDE_des),g" \
- -e "s,@LIB_des_appl\@,$(LIB_des_appl),g" \
- -e "s,@LIBS\@,$(LIBS),g" \
- $(srcdir)/krb5-config.in > $@
+ $(subst) $(srcdir)/krb5-config.in > $@.new
+ mv $@.new $@
chmod +x $@
+
+heimdal-gssapi.pc: heimdal-gssapi.pc.in
+ $(subst) $(srcdir)/heimdal-gssapi.pc.in > $@.new
+ mv $@.new $@
+
+EXTRA_DIST = \
+ $(man_MANS) \
+ heimdal-build.sh \
+ krb5-config.in \
+ heimdal-gssapi.pc.in \
+ kdc-log-analyze.pl
+
+CLEANFILES = \
+ krb5-config \
+ krb5-config.new \
+ heimdal-gssapi.pc \
+ heimdal-gssapi.pc.new
+
OpenPOWER on IntegriCloud