summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/lib/otp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/heimdal/lib/otp/Makefile.am')
-rw-r--r--crypto/heimdal/lib/otp/Makefile.am35
1 files changed, 32 insertions, 3 deletions
diff --git a/crypto/heimdal/lib/otp/Makefile.am b/crypto/heimdal/lib/otp/Makefile.am
index 97182f5..8e24251 100644
--- a/crypto/heimdal/lib/otp/Makefile.am
+++ b/crypto/heimdal/lib/otp/Makefile.am
@@ -1,8 +1,8 @@
-# $Id: Makefile.am,v 1.20 2001/09/02 19:37:12 assar Exp $
+# $Id: Makefile.am,v 1.22 2002/08/13 14:02:54 joda Exp $
include $(top_srcdir)/Makefile.am.common
-INCLUDES += $(INCLUDE_des)
+INCLUDES += $(INCLUDE_des) $(ROKEN_RENAME)
noinst_PROGRAMS = otptest
@@ -16,6 +16,12 @@ lib_LTLIBRARIES = libotp.la
libotp_la_LDFLAGS = -version-info 1:3:1
libotp_la_LIBADD = $(LIB_des) $(LIB_roken) $(LIB_NDBM)
+if HAVE_DB3
+ndbm_wrap = ndbm_wrap.c ndbm_wrap.h
+else
+ndbm_wrap =
+endif
+
libotp_la_SOURCES = \
otp.c \
otp_challenge.c \
@@ -26,4 +32,27 @@ libotp_la_SOURCES = \
otp_verify.c \
otp_locl.h \
otp_md.h \
- roken_rename.h
+ roken_rename.h \
+ $(ndbm_wrap) \
+ $(ROKEN_SRCS)
+
+if do_roken_rename
+ROKEN_SRCS = snprintf.c strcasecmp.c strncasecmp.c strlwr.c
+endif
+
+$(libotp_la_OBJECTS): $(ndbm_wrap)
+
+ndbm_wrap.c:
+ $(LN_S) $(srcdir)/../roken/ndbm_wrap.c .
+ndbm_wrap.h:
+ (echo '#define dbm_rename(X) __otp_ ## X'; cat $(srcdir)/../roken/ndbm_wrap.h) > ndbm_wrap.h
+
+
+snprintf.c:
+ $(LN_S) $(srcdir)/../roken/snprintf.c .
+strcasecmp.c:
+ $(LN_S) $(srcdir)/../roken/strcasecmp.c .
+strncasecmp.c:
+ $(LN_S) $(srcdir)/../roken/strncasecmp.c .
+strlwr.c:
+ $(LN_S) $(srcdir)/../roken/strlwr.c .
OpenPOWER on IntegriCloud