summaryrefslogtreecommitdiffstats
path: root/crypto/heimdal/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/heimdal/include/Makefile.am')
-rw-r--r--crypto/heimdal/include/Makefile.am113
1 files changed, 72 insertions, 41 deletions
diff --git a/crypto/heimdal/include/Makefile.am b/crypto/heimdal/include/Makefile.am
index c283cd2..a63c227 100644
--- a/crypto/heimdal/include/Makefile.am
+++ b/crypto/heimdal/include/Makefile.am
@@ -1,16 +1,16 @@
-# $Id: Makefile.am,v 1.33 2002/09/10 19:59:25 joda Exp $
+# $Id: Makefile.am 22396 2008-01-01 19:35:05Z lha $
include $(top_srcdir)/Makefile.am.common
-SUBDIRS = kadm5
+SUBDIRS = kadm5 hcrypto gssapi
noinst_PROGRAMS = bits make_crypto
-CHECK_LOCAL =
+CHECK_LOCAL = no-check-local
-INCLUDES += -DHOST=\"$(CANONICAL_HOST)\"
+AM_CPPFLAGS += -DHOST=\"$(CANONICAL_HOST)\"
-include_HEADERS = krb5-types.h
-noinst_HEADERS = crypto-headers.h
+nodist_include_HEADERS = krb5-types.h
+nodist_noinst_HEADERS = crypto-headers.h
krb5-types.h: bits$(EXEEXT)
./bits$(EXEEXT) krb5-types.h
@@ -18,39 +18,70 @@ krb5-types.h: bits$(EXEEXT)
crypto-headers.h: make_crypto$(EXEEXT)
./make_crypto$(EXEEXT) crypto-headers.h
-CLEANFILES = \
- asn1.h \
- asn1_err.h \
- base64.h \
- com_err.h \
- com_right.h \
- crypto-headers.h\
- der.h \
- des.h \
- editline.h \
- err.h \
- getarg.h \
- glob.h \
- gssapi.h \
- hdb.h \
- hdb_asn1.h \
- hdb_err.h \
- heim_err.h \
- kafs.h \
- krb5-protos.h \
- krb5-private.h \
- krb5-types.h \
- krb5.h \
- krb5_err.h \
- md4.h \
- md5.h \
- rc4.h \
- otp.h \
- parse_time.h \
- parse_units.h \
- resolve.h \
- roken-common.h \
- roken.h \
- sha.h \
- sl.h \
+CLEANFILES = \
+ cms_asn1.h \
+ der-protos.h \
+ digest_asn1.h \
+ hdb-protos.h \
+ heim_asn1.h \
+ heim_threads.h \
+ hex.h \
+ hx509-protos.h \
+ hx509.h \
+ hx509_err.h \
+ kx509_asn1.h \
+ kx509_err.h \
+ k524_err.h \
+ kdc-protos.h \
+ kdc.h \
+ krb5_asn1.h \
+ krb5_ccapi.h \
+ parse_bytes.h \
+ pkcs12_asn1.h \
+ pkcs8_asn1.h \
+ pkcs9_asn1.h \
+ pkinit_asn1.h \
+ rfc2459_asn1.h \
+ rtbl.h \
+ test-mem.h \
+ vers.h \
+ vis.h \
+ asn1.h \
+ asn1_err.h \
+ base64.h \
+ com_err.h \
+ com_right.h \
+ crypto-headers.h \
+ der.h \
+ editline.h \
+ err.h \
+ getarg.h \
+ glob.h \
+ gssapi.h \
+ hdb.h \
+ hdb_asn1.h \
+ hdb_err.h \
+ heim_err.h \
+ heimntlm.h \
+ heimntlm-protos.h \
+ kafs.h \
+ krb_err.h \
+ krb5-protos.h \
+ krb5-private.h \
+ krb5-types.h \
+ krb5.h \
+ krb5_err.h \
+ otp.h \
+ parse_time.h \
+ parse_units.h \
+ resolve.h \
+ roken-common.h \
+ roken.h \
+ sl.h \
+ windc_plugin.h \
+ locate_plugin.h \
xdbm.h
+
+DISTCLEANFILES = \
+ version.h \
+ version.h.in
OpenPOWER on IntegriCloud