summaryrefslogtreecommitdiffstats
path: root/contrib/traceroute/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/traceroute/configure.in')
-rw-r--r--contrib/traceroute/configure.in74
1 files changed, 74 insertions, 0 deletions
diff --git a/contrib/traceroute/configure.in b/contrib/traceroute/configure.in
new file mode 100644
index 0000000..5561baa
--- /dev/null
+++ b/contrib/traceroute/configure.in
@@ -0,0 +1,74 @@
+dnl @(#) $Header: configure.in,v 1.10 96/09/24 18:44:24 leres Exp $ (LBL)
+dnl
+dnl Copyright (c) 1995, 1996
+dnl The Regents of the University of California. All rights reserved.
+dnl
+dnl Process this file with autoconf to produce a configure script.
+dnl
+
+AC_INIT(traceroute.c)
+
+AC_CANONICAL_SYSTEM
+
+umask 002
+
+if test -z "$PWD" ; then
+ PWD=`pwd`
+fi
+
+AC_LBL_C_INIT(V_CCOPT, V_INCLS)
+
+AC_CHECK_HEADERS(malloc.h sys/select.h)
+
+AC_REPLACE_FUNCS(strerror)
+AC_CHECK_FUNCS(setlinebuf)
+
+AC_CHECK_LIB(socket, main)
+AC_CHECK_LIB(nsl, main)
+
+case "$target_os" in
+
+bsd4*)
+ AC_DEFINE(HAVE_RAW_OPTIONS)
+ ;;
+
+bsdi*)
+ AC_DEFINE(HAVE_RAW_OPTIONS)
+ ;;
+
+freebsd*)
+ AC_DEFINE(HAVE_RAW_OPTIONS)
+ ;;
+
+osf3*)
+ dnl Workaround around ip_hl vs. ip_vhl problem in netinet/ip.h
+ AC_DEFINE(__STDC__,2)
+ ;;
+
+solaris*)
+ AC_DEFINE(BYTESWAP_IP_LEN)
+ ;;
+esac
+
+AC_CHECK_TYPE(int32_t, int)
+AC_CHECK_TYPE(u_int32_t, u_int)
+
+AC_LBL_DEVEL(V_CCOPT)
+
+if test -r lbl/gnuc.h ; then
+ rm -f gnuc.h
+ ln -s lbl/gnuc.h gnuc.h
+fi
+
+AC_SUBST(V_CCOPT)
+AC_SUBST(V_INCLS)
+
+AC_PROG_INSTALL
+
+AC_OUTPUT(Makefile)
+
+if test -f .devel ; then
+ make depend
+fi
+
+exit 0
OpenPOWER on IntegriCloud