summaryrefslogtreecommitdiffstats
path: root/contrib/texinfo/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/texinfo/configure.in')
-rw-r--r--contrib/texinfo/configure.in58
1 files changed, 48 insertions, 10 deletions
diff --git a/contrib/texinfo/configure.in b/contrib/texinfo/configure.in
index 52950dc..425188b 100644
--- a/contrib/texinfo/configure.in
+++ b/contrib/texinfo/configure.in
@@ -1,42 +1,80 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $Id: configure.in,v 1.3 1996/10/03 18:33:52 karl Exp $
-AC_INIT(texinfo.texi)
+dnl $Id: configure.in,v 1.32 1998/03/03 18:29:17 karl Exp $
+dnl
+AC_INIT(makeinfo/makeinfo.c)
+AC_PREREQ(2.12)dnl Minimum Autoconf version required.
+AM_CONFIG_HEADER(config.h)
+
+AM_INIT_AUTOMAKE([texinfo], [3.12])
dnl Checks for programs.
+AC_PROG_CC
AC_PROG_GCC_TRADITIONAL
AC_PROG_INSTALL
AC_PROG_RANLIB
+# We do this for the sake of a more helpful warning in doc/Makefile.
+TEXMF='$(datadir)/texmf'
+AC_CHECK_PROG(TEXCONFIG, texconfig, true, false)
+$TEXCONFIG && eval `texconfig conf </dev/null | grep '^TEXMF='`
+AC_SUBST(TEXMF)
+
AC_ISC_POSIX
AC_MINIX
dnl Checks for libraries.
-# Needed on sysV68 for sigblock, sigsetmask.
-AC_CHECK_LIB(bsd, sigblock)
+AC_CHECK_LIB(z, gzdopen)
+# Needed on sysV68 for sigblock, sigsetmask. But check for it in libc first.
+AC_CHECK_FUNC(sigblock, , AC_CHECK_LIB(bsd, sigblock))
+
+# Some GNU/Linux systems (e.g., SuSE 4.3, 1996) don't have curses, but
+# rather ncurses. So we check for it.
TERMLIBS=
-for termlib in curses termcap terminfo termlib ; do
+for termlib in ncurses curses termcap terminfo termlib ; do
AC_CHECK_LIB(${termlib}, tputs,
[TERMLIBS="${TERMLIBS} -l${termlib}"; break])
done
AC_SUBST(TERMLIBS)
dnl Checks for header files.
+dnl Do not use <ncurses/termcap.h> unless we're linking with ncurses.
+if test "x$termlib" = xncurses; then
+ dnl Use AC_CHECK_HEADERS so the HAVE_*_H symbol gets defined.
+ AC_CHECK_HEADERS(ncurses/termcap.h)
+fi
AC_HEADER_STDC
-AC_CHECK_HEADERS(unistd.h termios.h termio.h strings.h string.h varargs.h \
- sys/time.h sys/fcntl.h sys/ttold.h sys/ptem.h sys/file.h)
+AC_CHECK_HEADERS(fcntl.h pwd.h string.h strings.h termcap.h termio.h \
+ termios.h unistd.h \
+ sys/fcntl.h sys/file.h sys/ptem.h sys/time.h sys/ttold.h sys/wait.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_OFF_T
+AC_TYPE_SIGNAL
AC_C_CONST
AC_STRUCT_TM
dnl Checks for library functions.
AC_FUNC_ALLOCA
+AC_FUNC_VPRINTF
AC_FUNC_SETVBUF_REVERSED
AC_CHECK_FUNCS(setvbuf getcwd memset bzero strchr strcasecmp \
- vfprintf vsprintf strerror sigprocmask sigsetmask)
+ sigprocmask sigsetmask)
dnl strcasecmp, strerror, xmalloc, xrealloc, probably others should be added.
-AC_REPLACE_FUNCS(memcpy memmove strdup)
+AC_REPLACE_FUNCS(memcpy memmove strdup strerror)
+
+dnl Set of available languages and i18n macros.
+ALL_LINGUAS="de fr"
+AM_GNU_GETTEXT
+AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
-AC_OUTPUT(Makefile libtxi/Makefile makeinfo/Makefile info/Makefile util/Makefile emacs/Makefile)
+AC_OUTPUT([Makefile \
+ doc/Makefile \
+ info/Makefile \
+ intl/Makefile \
+ lib/Makefile \
+ makeinfo/Makefile \
+ po/Makefile.in \
+ util/Makefile \
+ ],
+ [sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in >po/Makefile])
OpenPOWER on IntegriCloud