summaryrefslogtreecommitdiffstats
path: root/contrib/subversion/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/subversion/configure.ac')
-rw-r--r--contrib/subversion/configure.ac36
1 files changed, 27 insertions, 9 deletions
diff --git a/contrib/subversion/configure.ac b/contrib/subversion/configure.ac
index b1748ce..169b34b 100644
--- a/contrib/subversion/configure.ac
+++ b/contrib/subversion/configure.ac
@@ -460,6 +460,7 @@ powerpc-apple-darwin*)
SVN_FS_WANT_DB_PATCH=14
;;
esac
+db_alt_version="5.x"
# Look for libdb4.so first:
SVN_LIB_BERKELEY_DB($SVN_FS_WANT_DB_MAJOR, $SVN_FS_WANT_DB_MINOR,
$SVN_FS_WANT_DB_PATCH, [db4 db])
@@ -1117,6 +1118,13 @@ elif test "$enable_optimization" = "no"; then
# # do nothing
fi
+dnl Dump the current compiler options
+AC_MSG_NOTICE([C compiler flags: $CFLAGS])
+AC_MSG_NOTICE([ user-defined: $CUSERFLAGS])
+AC_MSG_NOTICE([ maintainer-mode: $CMAINTAINERFLAGS])
+AC_MSG_NOTICE([C++ compiler flags: $CXXFLAGS])
+AC_MSG_NOTICE([ user-defined: $CXXUSERFLAGS])
+AC_MSG_NOTICE([ maintainer-mode: $CXXMAINTAINERFLAGS])
AC_ARG_ENABLE(full-version-match,
AS_HELP_STRING([--disable-full-version-match],
@@ -1504,18 +1512,28 @@ dnl Configure is long - users tend to miss warnings printed during it.
dnl Hence, print a warnings about what we did and didn't configure at the
dnl end, where people will actually see them.
-if test "$svn_lib_berkeley_db" = "no" && test "$with_berkeley_db" != "no"; then
- db_version="$SVN_FS_WANT_DB_MAJOR.$SVN_FS_WANT_DB_MINOR.$SVN_FS_WANT_DB_PATCH"
- AC_MSG_WARN([we have configured without BDB filesystem support
+if test "$svn_have_berkeley_db" = "no6" && test "$enable_bdb6" != "no"; then
+ AC_MSG_WARN([We have configured without BDB filesystem support
-You don't seem to have Berkeley DB version $db_version or newer
-installed and linked to APR-UTIL. We have created a Makefile which will build
-Subversion without support for the Berkeley DB back-end. You can find the
-latest version of Berkeley DB here:
+Berkeley DB 6 was found, but not used. Please re-run configure (see
+./config.nice) with the '--enable-bdb6' flag to use it,
+or explicitly specify '--disable-bdb6' or '--without-berkeley-db'
+to silence this warning.
- http://www.oracle.com/technetwork/products/berkeleydb/downloads/index.html
+Please note that some versions of Berkeley DB 6+ are under the GNU Affero
+General Public License, version 3:
+https://oss.oracle.com/pipermail/bdb/2013-June/000056.html
-or explicitly specify --without-berkeley-db to silence this warning.
+The AGPL-3.0 licence may impose special requirements for making available
+source code of server-side software. The text of the licence is:
+https://www.gnu.org/licenses/agpl-3.0.html
+http://opensource.org/licenses/AGPL-3.0
+
+The Berkeley DB backend to Subversion is deprecated; see
+http://subversion.apache.org/docs/release-notes/1.8#bdb-deprecated
+
+The Subversion developers have not tested Subversion with Berkeley DB 6 for
+technical problems or bugs.
])
fi
OpenPOWER on IntegriCloud