summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/Socket/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/Socket/Makefile.PL')
-rw-r--r--contrib/perl5/ext/Socket/Makefile.PL8
1 files changed, 5 insertions, 3 deletions
diff --git a/contrib/perl5/ext/Socket/Makefile.PL b/contrib/perl5/ext/Socket/Makefile.PL
index 3819143..339c45a 100644
--- a/contrib/perl5/ext/Socket/Makefile.PL
+++ b/contrib/perl5/ext/Socket/Makefile.PL
@@ -1,7 +1,9 @@
use ExtUtils::MakeMaker;
+use Config;
WriteMakefile(
- NAME => 'Socket',
+ NAME => 'Socket',
VERSION_FROM => 'Socket.pm',
- MAN3PODS => {}, # Pods will be built by installman.
- XSPROTOARG => '-noprototypes', # XXX remove later?
+ ($Config{libs} =~ /(-lsocks\S*)/ ? (LIBS => [ "$1" ] ) : ()),
+ MAN3PODS => {}, # Pods will be built by installman.
+ XSPROTOARG => '-noprototypes', # XXX remove later?
);
OpenPOWER on IntegriCloud