summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/SDBM_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/SDBM_File/Makefile.PL')
-rw-r--r--contrib/perl5/ext/SDBM_File/Makefile.PL35
1 files changed, 35 insertions, 0 deletions
diff --git a/contrib/perl5/ext/SDBM_File/Makefile.PL b/contrib/perl5/ext/SDBM_File/Makefile.PL
new file mode 100644
index 0000000..b639b29
--- /dev/null
+++ b/contrib/perl5/ext/SDBM_File/Makefile.PL
@@ -0,0 +1,35 @@
+use ExtUtils::MakeMaker;
+
+# The existence of the ./sdbm/Makefile.PL file causes MakeMaker
+# to automatically include Makefile code for the targets
+# config, all, clean, realclean and sdbm/Makefile
+# which perform the corresponding actions in the subdirectory.
+
+$define = ($^O eq 'MSWin32') ? '-DMSDOS' : '';
+if ($^O eq 'MSWin32') { $myextlib = 'sdbm\\libsdbm$(LIB_EXT)'; }
+else { $myextlib = 'sdbm/libsdbm$(LIB_EXT)'; }
+
+WriteMakefile(
+ NAME => 'SDBM_File',
+ MYEXTLIB => $myextlib,
+ MAN3PODS => ' ', # Pods will be built by installman.
+ XSPROTOARG => '-noprototypes', # XXX remove later?
+ VERSION_FROM => 'SDBM_File.pm',
+ DEFINE => $define,
+ );
+
+sub MY::postamble {
+ if ($^O ne 'VMS') {
+ '
+$(MYEXTLIB): sdbm/Makefile
+ cd sdbm && $(MAKE) all
+';
+ } else {
+ '
+$(MYEXTLIB) : [.sdbm]descrip.mms
+ set def [.sdbm]
+ $(MMS) all
+ set def [-]
+';
+ }
+}
OpenPOWER on IntegriCloud