summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/IO/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/IO/Makefile.PL')
-rw-r--r--contrib/perl5/ext/IO/Makefile.PL11
1 files changed, 6 insertions, 5 deletions
diff --git a/contrib/perl5/ext/IO/Makefile.PL b/contrib/perl5/ext/IO/Makefile.PL
index 6a2d50d..095d7c2 100644
--- a/contrib/perl5/ext/IO/Makefile.PL
+++ b/contrib/perl5/ext/IO/Makefile.PL
@@ -1,8 +1,9 @@
use ExtUtils::MakeMaker;
+use Config qw(%Config);
+
WriteMakefile(
- NAME => 'IO',
- MAN3PODS => {}, # Pods will be built by installman.
- XSPROTOARG => '-noprototypes', # XXX remove later?
- VERSION_FROM => 'lib/IO/Handle.pm',
- XS_VERSION => 1.15
+ VERSION_FROM => "IO.pm",
+ NAME => "IO",
+ OBJECT => '$(O_FILES)',
+ MAN3PODS => {}, # Pods will be built by installman.
);
OpenPOWER on IntegriCloud