summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/File/Glob/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/File/Glob/Makefile.PL')
-rw-r--r--contrib/perl5/ext/File/Glob/Makefile.PL21
1 files changed, 21 insertions, 0 deletions
diff --git a/contrib/perl5/ext/File/Glob/Makefile.PL b/contrib/perl5/ext/File/Glob/Makefile.PL
new file mode 100644
index 0000000..98781c9
--- /dev/null
+++ b/contrib/perl5/ext/File/Glob/Makefile.PL
@@ -0,0 +1,21 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ NAME => 'File::Glob',
+ VERSION_FROM => 'Glob.pm',
+ MAN3PODS => {}, # Pods will be built by installman.
+ OBJECT => 'bsd_glob$(OBJ_EXT) Glob$(OBJ_EXT)',
+
+## uncomment for glob debugging (will cause make test to fail)
+# DEFINE => '-DGLOB_DEBUG',
+# OPTIMIZE => '-g',
+);
+use Config;
+sub MY::cflags {
+ package MY;
+ my $inherited = shift->SUPER::cflags(@_);
+ if ($Config::Config{archname} =~ /^aix/ and
+ $Config::Config{use64bitall} eq 'define') {
+ $inherited =~ s/\s-O\d?//m;
+ }
+ $inherited;
+}
OpenPOWER on IntegriCloud