summaryrefslogtreecommitdiffstats
path: root/contrib/perl5/ext/B/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/perl5/ext/B/Makefile.PL')
-rw-r--r--contrib/perl5/ext/B/Makefile.PL36
1 files changed, 13 insertions, 23 deletions
diff --git a/contrib/perl5/ext/B/Makefile.PL b/contrib/perl5/ext/B/Makefile.PL
index 80e5e1b..cb9696b 100644
--- a/contrib/perl5/ext/B/Makefile.PL
+++ b/contrib/perl5/ext/B/Makefile.PL
@@ -16,31 +16,21 @@ if ($^O eq 'MSWin32') {
WriteMakefile(
NAME => "B",
VERSION => "a5",
- MAN3PODS => {},
+ PL_FILES => { 'defsubs_h.PL' => 'defsubs.h' },
+ MAN3PODS => {},
clean => {
- FILES => "perl$e byteperl$e *$o B.c *~"
+ FILES => "perl$e *$o B.c defsubs.h *~"
}
-);
+);
-sub MY::post_constants {
- "\nLIBS = $Config{libs}\n"
-}
+package MY;
-# Leave out doing byteperl for now. Probably should be built in the
-# core directory or somewhere else rather than here
-#sub MY::top_targets {
-# my $self = shift;
-# my $targets = $self->MM::top_targets();
-# $targets =~ s/^(all ::.*)$/$1 byteperl$e/m;
-# return <<"EOT" . $targets;
+sub post_constants {
+ "\nLIBS = $Config::Config{libs}\n"
+}
-#
-# byteperl is *not* a standard perl+XSUB executable. It's a special
-# program for running standalone bytecode executables. It isn't an XSUB
-# at the moment because a standlone Perl program needs to set up curpad
-# which is overwritten on exit from an XSUB.
-#
-#byteperl$e : byteperl$o B$o \$(PERL_SRC)/byterun$o
-# \$(CC) ${exeout_flag}byteperl$e byteperl$o B$o byterun$o \$(LDFLAGS) \$(PERL_ARCHLIB)/CORE/$Config{libperl} \$(LIBS)
-#EOT
-#}
+sub postamble {
+'
+B$(OBJ_EXT) : defsubs.h
+'
+}
OpenPOWER on IntegriCloud