summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/tools/bugpoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/tools/bugpoint/CMakeLists.txt')
-rw-r--r--contrib/llvm/tools/bugpoint/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/llvm/tools/bugpoint/CMakeLists.txt b/contrib/llvm/tools/bugpoint/CMakeLists.txt
new file mode 100644
index 0000000..e06feb1
--- /dev/null
+++ b/contrib/llvm/tools/bugpoint/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(LLVM_LINK_COMPONENTS asmparser instrumentation scalaropts ipo
+ linker bitreader bitwriter)
+
+add_llvm_tool(bugpoint
+ BugDriver.cpp
+ CrashDebugger.cpp
+ ExecutionDriver.cpp
+ ExtractFunction.cpp
+ FindBugs.cpp
+ Miscompilation.cpp
+ OptimizerDriver.cpp
+ ToolRunner.cpp
+ bugpoint.cpp
+ )
OpenPOWER on IntegriCloud