summaryrefslogtreecommitdiffstats
path: root/contrib/llvm/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/llvm/lib/CodeGen/CMakeLists.txt')
-rw-r--r--contrib/llvm/lib/CodeGen/CMakeLists.txt81
1 files changed, 81 insertions, 0 deletions
diff --git a/contrib/llvm/lib/CodeGen/CMakeLists.txt b/contrib/llvm/lib/CodeGen/CMakeLists.txt
new file mode 100644
index 0000000..3e38872
--- /dev/null
+++ b/contrib/llvm/lib/CodeGen/CMakeLists.txt
@@ -0,0 +1,81 @@
+add_llvm_library(LLVMCodeGen
+ Analysis.cpp
+ AggressiveAntiDepBreaker.cpp
+ BranchFolding.cpp
+ CalcSpillWeights.cpp
+ CodePlacementOpt.cpp
+ CriticalAntiDepBreaker.cpp
+ DeadMachineInstructionElim.cpp
+ DwarfEHPrepare.cpp
+ ELFCodeEmitter.cpp
+ ELFWriter.cpp
+ ExactHazardRecognizer.cpp
+ GCMetadata.cpp
+ GCMetadataPrinter.cpp
+ GCStrategy.cpp
+ IfConversion.cpp
+ IntrinsicLowering.cpp
+ LLVMTargetMachine.cpp
+ LatencyPriorityQueue.cpp
+ LiveInterval.cpp
+ LiveIntervalAnalysis.cpp
+ LiveStackAnalysis.cpp
+ LiveVariables.cpp
+ LowerSubregs.cpp
+ MachineBasicBlock.cpp
+ MachineCSE.cpp
+ MachineDominators.cpp
+ MachineFunction.cpp
+ MachineFunctionAnalysis.cpp
+ MachineFunctionPass.cpp
+ MachineFunctionPrinterPass.cpp
+ MachineInstr.cpp
+ MachineLICM.cpp
+ MachineLoopInfo.cpp
+ MachineModuleInfo.cpp
+ MachineModuleInfoImpls.cpp
+ MachinePassRegistry.cpp
+ MachineRegisterInfo.cpp
+ MachineSSAUpdater.cpp
+ MachineSink.cpp
+ MachineVerifier.cpp
+ ObjectCodeEmitter.cpp
+ OcamlGC.cpp
+ OptimizeExts.cpp
+ OptimizePHIs.cpp
+ PHIElimination.cpp
+ Passes.cpp
+ PostRASchedulerList.cpp
+ PreAllocSplitting.cpp
+ ProcessImplicitDefs.cpp
+ PrologEpilogInserter.cpp
+ PseudoSourceValue.cpp
+ RegAllocFast.cpp
+ RegAllocLinearScan.cpp
+ RegAllocLocal.cpp
+ RegAllocPBQP.cpp
+ RegisterCoalescer.cpp
+ RegisterScavenging.cpp
+ ScheduleDAG.cpp
+ ScheduleDAGEmit.cpp
+ ScheduleDAGInstrs.cpp
+ ScheduleDAGPrinter.cpp
+ ShadowStackGC.cpp
+ ShrinkWrapping.cpp
+ SimpleRegisterCoalescing.cpp
+ SjLjEHPrepare.cpp
+ SlotIndexes.cpp
+ Spiller.cpp
+ StackProtector.cpp
+ StackSlotColoring.cpp
+ StrongPHIElimination.cpp
+ TailDuplication.cpp
+ TargetInstrInfoImpl.cpp
+ TargetLoweringObjectFileImpl.cpp
+ TwoAddressInstructionPass.cpp
+ UnreachableBlockElim.cpp
+ VirtRegMap.cpp
+ VirtRegRewriter.cpp
+ )
+
+target_link_libraries (LLVMCodeGen LLVMCore LLVMScalarOpts)
OpenPOWER on IntegriCloud