summaryrefslogtreecommitdiffstats
path: root/contrib/libxo/xopo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libxo/xopo/Makefile.am')
-rw-r--r--contrib/libxo/xopo/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/contrib/libxo/xopo/Makefile.am b/contrib/libxo/xopo/Makefile.am
new file mode 100644
index 0000000..192d308
--- /dev/null
+++ b/contrib/libxo/xopo/Makefile.am
@@ -0,0 +1,43 @@
+#
+# Copyright 2014, Juniper Networks, Inc.
+# All rights reserved.
+# This SOFTWARE is licensed under the LICENSE provided in the
+# ../Copyright file. By downloading, installing, copying, or otherwise
+# using the SOFTWARE, you agree to be bound by the terms of that
+# LICENSE.
+
+if LIBXO_WARNINGS_HIGH
+LIBXO_WARNINGS = HIGH
+endif
+include ${top_srcdir}/warnings.mk
+
+AM_CFLAGS = \
+ -DLIBXO_XMLSOFT_NEED_PRIVATE \
+ -I${top_builddir} \
+ -I${top_srcdir} \
+ -I${top_srcdir}/libxo \
+ ${WARNINGS}
+
+LIBS = \
+ ${LIBXO_LIBS}
+
+bin_PROGRAMS = xopo
+
+xopo_SOURCES = xopo.c
+#xo_LDADD = ../libxo/libxo.la
+#xo_LDFLAGS = -static
+
+LDADD = \
+ ${top_builddir}/libxo/libxo.la
+
+if HAVE_HUMANIZE_NUMBER
+LDADD += -lutil
+endif
+
+man_MANS = xopo.1
+
+EXTRA_DIST = xopo.1
+
+install-data-hook:
+ for file in ${man_MANS}; do \
+ cat ../libxo/add.man >> ${DESTDIR}${man1dir}/$$file ; done
OpenPOWER on IntegriCloud