summaryrefslogtreecommitdiffstats
path: root/contrib/libstdc++/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libstdc++/configure.in')
-rw-r--r--contrib/libstdc++/configure.in48
1 files changed, 34 insertions, 14 deletions
diff --git a/contrib/libstdc++/configure.in b/contrib/libstdc++/configure.in
index 663e4f3..d30e61b 100644
--- a/contrib/libstdc++/configure.in
+++ b/contrib/libstdc++/configure.in
@@ -12,13 +12,12 @@ ORIGINAL_LD_FOR_MULTILIBS=$LD
PACKAGE=libstdc++
AC_SUBST(PACKAGE)
-# For typical GNU versioning info, format is MAJOR.MINOR.MICRO
-release_VERSION=3.1.0
-AC_SUBST(release_VERSION)
# For libtool versioning info, format is CURRENT:REVISION:AGE
-libtool_VERSION=4:0:0
+libtool_VERSION=5:1:0
AC_SUBST(libtool_VERSION)
+GLIBCPP_TOPREL_CONFIGURE
+
# Gets build, host, target, *_vendor, *_cpu, *_os, etc.
# AC 2.5x sets target_alias iff the user specified --target, but we use it
# everywhere, so we set it here just to be sure. In AC 2.13
@@ -27,14 +26,14 @@ AC_CANONICAL_SYSTEM
target_alias=${target_alias-$target}
AC_SUBST(target_alias)
-AM_INIT_AUTOMAKE($PACKAGE, $release_VERSION)
-AM_CONFIG_HEADER(config.h)
-
# Runs configure.host and configure.target, as well as finds CC, CXX
# and assorted other critical bits. Have to run this before the
# GLIBCPP_ENABLE_* macros below.
GLIBCPP_CONFIGURE(.)
+AM_INIT_AUTOMAKE($PACKAGE, $gcc_version)
+AM_CONFIG_HEADER(config.h)
+
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
AC_SUBST(enable_shared)
@@ -51,13 +50,15 @@ GLIBCPP_ENABLE_CLOCALE
GLIBCPP_ENABLE_C_MBCHAR([yes])
GLIBCPP_ENABLE_C99([yes])
GLIBCPP_ENABLE_LONG_LONG([yes])
-GLIBCPP_ENABLE_CHEADERS([c_std])
+GLIBCPP_ENABLE_CHEADERS([$c_model])
GLIBCPP_ENABLE_THREADS
GLIBCPP_ENABLE_CXX_FLAGS([none])
GLIBCPP_ENABLE_SJLJ_EXCEPTIONS
GLIBCPP_ENABLE_LIBUNWIND_EXCEPTIONS
GLIBCPP_ENABLE_CONCEPT_CHECKS
+# Check for headers necessary for libsupc++ using dyn-string.c/cxa_demangle.c
+AC_CHECK_HEADERS(string.h stdlib.h)
if test -n "$with_cross_host" || test x"$build" != x"$host"; then
@@ -156,6 +157,28 @@ if test -n "$with_cross_host" || test x"$build" != x"$host"; then
GLIBCPP_CHECK_WCHAR_T_SUPPORT
os_include_dir="config/os/mingw32"
;;
+changequote(,)dnl
+ *-qnx6.[12]*)
+changequote([,])dnl
+ SECTION_FLAGS='-ffunction-sections -fdata-sections'
+ AC_SUBST(SECTION_FLAGS)
+ GLIBCPP_CHECK_LINKER_FEATURES
+ GLIBCPP_CHECK_COMPLEX_MATH_SUPPORT
+ GLIBCPP_CHECK_WCHAR_T_SUPPORT
+ os_include_dir="config/os/qnx/qnx6.1"
+ AC_DEFINE(HAVE_COSF)
+ AC_DEFINE(HAVE_COSL)
+ AC_DEFINE(HAVE_COSHF)
+ AC_DEFINE(HAVE_COSHL)
+ AC_DEFINE(HAVE_LOGF)
+ AC_DEFINE(HAVE_LOGL)
+ AC_DEFINE(HAVE_LOG10F)
+ AC_DEFINE(HAVE_LOG10L)
+ AC_DEFINE(HAVE_SINF)
+ AC_DEFINE(HAVE_SINL)
+ AC_DEFINE(HAVE_SINHF)
+ AC_DEFINE(HAVE_SINHL)
+ ;;
*)
os_include_dir="config/os/newlib"
AC_DEFINE(HAVE_HYPOT)
@@ -247,7 +270,7 @@ else
# Check for available headers.
AC_CHECK_HEADERS([nan.h ieeefp.h endian.h sys/isa_defs.h machine/endian.h \
- machine/param.h sys/machine.h fp.h locale.h float.h inttypes.h gconv.h])
+ machine/param.h sys/machine.h fp.h locale.h float.h inttypes.h gconv.h sys/types.h])
GLIBCPP_CHECK_COMPILER_FEATURES
GLIBCPP_CHECK_LINKER_FEATURES
@@ -293,9 +316,6 @@ else
multilib_arg=
fi
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE=v3
-
# Export all the install information
GLIBCPP_EXPORT_INSTALL_INFO
@@ -379,11 +399,11 @@ if test ! -f stamp-sanity-warned; then
touch stamp-sanity-warned
echo ""
echo "Please make certain that you read the installation information here:"
- echo " faster => ${srcdir}/docs/install.html"
+ echo " faster => ${srcdir}/docs/html/install.html"
echo " slower => <URL:http://gcc.gnu.org/onlinedocs/libstdc++/install.html>"
echo ""
echo "and the configuration information here:"
- echo " faster => ${srcdir}/docs/configopts.html"
+ echo " faster => ${srcdir}/docs/html/configopts.html"
echo " slower => <URL:http://gcc.gnu.org/onlinedocs/libstdc++/configopts.html>"
echo ""
echo "before proceeding with ${_cv_gnu_make_command}."
OpenPOWER on IntegriCloud