summaryrefslogtreecommitdiffstats
path: root/contrib/libstdc++/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/libstdc++/configure.in')
-rw-r--r--contrib/libstdc++/configure.in119
1 files changed, 119 insertions, 0 deletions
diff --git a/contrib/libstdc++/configure.in b/contrib/libstdc++/configure.in
new file mode 100644
index 0000000..204d4a8
--- /dev/null
+++ b/contrib/libstdc++/configure.in
@@ -0,0 +1,119 @@
+# This file is a shell script fragment that supplies the information
+# necessary for a configure script to process the program in
+# this directory. For more information, look at ../configure.
+
+if [ "${srcdir}" = "." ] ; then
+ if [ "${with_target_subdir}" != "." ] ; then
+ topsrcdir=${with_multisrctop}../..
+ else
+ topsrcdir=${with_multisrctop}..
+ fi
+else
+ topsrcdir=${srcdir}/..
+fi
+
+if [ -d ${topsrcdir}/gcc ] ; then
+ configdirs="tests testsuite"
+else
+ configdirs="tests"
+fi
+srctrigger=sinst.cc
+srcname="ANSI C++ library"
+package_makefile_frag=Make.pack
+package_makefile_rules_frag=Make.pack.r
+
+# per-host:
+
+# per-target:
+
+echo "# Warning: this fragment is automatically generated" > temp.mt
+frags=
+
+# If they didn't specify --enable-shared, don't generate shared libs.
+case "${enable_shared}" in
+ yes) shared=yes ;;
+ no) shared=no ;;
+ *libstdc++*) shared=yes ;;
+ *) shared=no ;;
+esac
+
+if [ "${shared}" = "yes" ]; then
+ case "${target}" in
+ hppa*-*-*) frags=../../config/mh-papic ;;
+ i[3456]86-*-*) frags=../../config/mh-x86pic ;;
+ alpha*-*-linux*) frags=../../config/mh-elfalphapic ;;
+
+ # There doesn't seem to be a simpler way to say all-ppc except AIX
+ *-*-aix*) ;;
+ powerpc*-* | ppc*-*) frags=../../config/mh-ppcpic ;;
+
+ *-*-*) frags=../../config/mh-${target_cpu}pic ;;
+ esac
+ case "${target}" in
+ *-dec-osf*) frags="${frags} dec-osf.ml";;
+ *-*-hpux*) frags="${frags} hpux.ml" ;;
+ *-*-irix[56]*) frags="${frags} irix5.ml" ;;
+ *-*-linux*aout*) ;;
+ *-*-linux*) frags="${frags} linux.ml" ;;
+ *-*-openbsd*) frags="${frags} openbsd.ml" ;;
+ *-*-sysv4*) frags="${frags} elf.ml" ;;
+ *-*-solaris*) frags="${frags} sol2shm.ml" ;;
+ *-*-sunos4*) frags="${frags} sunos4.ml" ;;
+ *-*-aix*) frags="${frags} aix.ml" ;;
+ esac
+fi
+
+# Make sure the right flags are defined for multi-threading.
+case "${target}" in
+ alpha*-*-linux-gnulibc1) frags="${frags} linux.mt" ;;
+ powerpc*-*-linux-gnulibc1) frags="${frags} linux.mt" ;;
+ *-*-linux-gnu) frags="${frags} linux.mt" ;;
+ *-*-openbsd*)
+ case "x${enable_threads}" in
+ xyes|xposix) frags="${frags} openbsd.mt" ;;
+ esac;;
+ m68k-motorola-sysv) frags="${frags} delta.mt" ;;
+esac
+
+for frag in ${frags}; do
+ case ${frag} in
+ ../* )
+ if [ ${srcdir} = . ]; then
+ [ -n "${with_target_subdir}" ] && frag=../${frag}
+ [ -n "${with_multisrctop}" ] && frag=${with_multisrctop}${frag}
+ fi
+ ;;
+ esac
+ frag=${srcdir}/config/$frag
+ if [ -f ${frag} ]; then
+ echo "Appending ${frag} to target-mkfrag"
+ echo "# Following fragment copied from ${frag}" >> temp.mt
+ cat ${frag} >> temp.mt
+ fi
+done
+
+target_makefile_frag=target-mkfrag
+${moveifchange} temp.mt target-mkfrag
+
+LIBDIR=yes
+TO_TOPDIR=../
+ALL='libs'
+XCXXINCLUDES="-I${srcdir} -I${srcdir}/stl -I${TO_TOPDIR}libio -I${srcdir}/${TO_TOPDIR}libio"
+MOSTLYCLEAN='*.o pic stamp-picdir core so_locations $(MOSTLYCLEAN_JUNK)'
+CLEAN='$(CLEAN_JUNK)'
+EXTRA_DISTCLEAN='target-mkfrag'
+
+(. ${srcdir}/${TO_TOPDIR}libio/config.shared) >${package_makefile_frag} 2>${package_makefile_rules_frag}
+
+# post-target:
+
+# If cross-compiling, we install in $(tooldir).
+if [ -n "${with_cross_host}" ] ; then
+ rm -f Makefile.tem
+ sed \
+ -e 's|\(INSTALLDIR[ ]*=[ ]*\)[^ ;]*|\1$(tooldir)/lib|' \
+ Makefile >Makefile.tem
+ mv -f Makefile.tem Makefile
+fi
+
+. ${topsrcdir}/config-ml.in
OpenPOWER on IntegriCloud