summaryrefslogtreecommitdiffstats
path: root/contrib/groff/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/groff/configure.ac')
-rw-r--r--contrib/groff/configure.ac29
1 files changed, 24 insertions, 5 deletions
diff --git a/contrib/groff/configure.ac b/contrib/groff/configure.ac
index b8f111a..75c4799 100644
--- a/contrib/groff/configure.ac
+++ b/contrib/groff/configure.ac
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT
+AC_CONFIG_HEADERS(src/include/config.h:src/include/config.hin)
AC_CONFIG_SRCDIR([src/roff/groff/groff.cc])
dnl checks for programs
GROFF_SRCDIR
@@ -14,6 +15,7 @@ AC_PATH_PROG(PERLPATH, perl, /usr/bin/perl)
GROFF_PROG_YACC
AC_PROG_RANLIB
GROFF_INSTALL_SH
+GROFF_INSTALL_INFO
AC_PROG_INSTALL
AC_PROG_LN_S
dnl use a dummy substitution if no csh hack is necessary to avoid errors
@@ -22,20 +24,25 @@ GROFF_CSH_HACK(SH_SCRIPT_SED_CMD='1s/.*/:/', SH_SCRIPT_SED_CMD='1s/a/a/')
AC_SUBST(SH_SCRIPT_SED_CMD)
dnl checks for headers
AC_CHECK_HEADERS(stdlib.h unistd.h dirent.h limits.h sys/dir.h \
- string.h strings.h math.h)
+ string.h strings.h math.h stdint.h sys/time.h)
GROFF_ISC_SYSV3
GROFF_POSIX
GROFF_SRAND
+GROFF_NEED_DECLARATION(gettimeofday)
GROFF_NEED_DECLARATION(hypot)
GROFF_NEED_DECLARATION(popen)
GROFF_NEED_DECLARATION(pclose)
GROFF_NEED_DECLARATION(putenv)
+GROFF_NEED_DECLARATION(strcasecmp)
GROFF_NEED_DECLARATION(strncasecmp)
GROFF_SYS_NERR
GROFF_SYS_ERRLIST
GROFF_OSFCN_H
GROFF_LIMITS_H
+GROFF_INTTYPES_H
dnl checks for typedefs
+GROFF_UNSIGNED_LONG_LONG
+GROFF_UINTMAX_T
GROFF_TIME_T
AC_TYPE_SIGNAL
GROFF_STRUCT_EXCEPTION
@@ -45,9 +52,9 @@ dnl checks for functions
AC_FUNC_MMAP
saved_libs="$LIBS"
LIBS="$LIBS -lc $LIBM"
-AC_REPLACE_FUNCS(fmod strtol getcwd strerror putenv)
+AC_REPLACE_FUNCS(fmod getcwd putenv snprintf strerror strtol)
LIBS="$saved_libs"
-AC_CHECK_FUNCS(rename strcasecmp strncasecmp strsep strdup)
+AC_CHECK_FUNCS(gettimeofday isatty rename strcasecmp strncasecmp strsep)
GROFF_MKSTEMP
AC_DECL_SYS_SIGLIST
dnl checks for compiler characteristics
@@ -60,6 +67,18 @@ GROFF_BROKEN_SPOOLER_FLAGS
GROFF_PAGE
GROFF_G
GROFF_TMAC
-$srcdir/mkinstalldirs src/xditview
-AC_CONFIG_FILES([Makefile src/xditview/Imakefile])
+GROFF_HTML_PROGRAMS
+AC_CONFIG_FILES(stamp-h, [echo timestamp > stamp-h])
+AC_CONFIG_FILES([Makefile doc/Makefile src/xditview/Imakefile])
AC_OUTPUT
+dnl
+AC_MSG_NOTICE([
+
+ Configuration completed.
+
+ You can now say `make' to compile the groff package and `make install'
+ to install it afterwards.
+
+ If you want to compile xditview, change the directory to `src/xditview'
+ and follow the instructions given in the file `INSTALL'.
+])
OpenPOWER on IntegriCloud