summaryrefslogtreecommitdiffstats
path: root/contrib/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gcc/configure.in')
-rw-r--r--contrib/gcc/configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/contrib/gcc/configure.in b/contrib/gcc/configure.in
index e43c157..c9e2bbf 100644
--- a/contrib/gcc/configure.in
+++ b/contrib/gcc/configure.in
@@ -1399,11 +1399,10 @@ changequote(,)dnl
changequote([,])dnl
xm_file="xm-siglist.h xm-alloca.h ${xm_file}"
xm_defines="USG POSIX SMALL_ARG_MAX"
+ tm_file=i386/sol2.h
if test x$gas = xyes; then
# Only needed if gas does not support -s
- tm_file=i386/sol2gas.h
- else
- tm_file=i386/sol2.h
+ tm_file="i386/sol2gas.h ${tm_file}"
fi
tmake_file=i386/t-sol2
extra_parts="crt1.o crti.o crtn.o gcrt1.o gmon.o crtbegin.o crtend.o"
@@ -1689,7 +1688,7 @@ changequote([,])dnl
extra_headers=math-68881.h
;;
m68000-hp-hpux*) # HP 9000 series 300
- xm_file="xm_alloca.h ${xm_file}"
+ xm_file="xm-alloca.h ${xm_file}"
xm_defines="USG NO_SYS_SIGLIST"
if test x$gas = xyes
then
@@ -1890,7 +1889,7 @@ changequote([,])dnl
extra_headers=math-68881.h
;;
m68k-hp-hpux7*) # HP 9000 series 300 running HPUX version 7.
- xm_file="xm_alloca.h ${xm_file}"
+ xm_file="xm-alloca.h ${xm_file}"
xm_defines="USG NO_SYS_SIGLIST"
if test x$gas = xyes
then
@@ -1906,7 +1905,7 @@ changequote([,])dnl
float_format=m68k
;;
m68k-hp-hpux*) # HP 9000 series 300
- xm_file="xm_alloca.h ${xm_file}"
+ xm_file="xm-alloca.h ${xm_file}"
xm_defines="USG NO_SYS_SIGLIST"
if test x$gas = xyes
then
OpenPOWER on IntegriCloud