summaryrefslogtreecommitdiffstats
path: root/contrib/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gcc/configure.in')
-rw-r--r--contrib/gcc/configure.in19
1 files changed, 14 insertions, 5 deletions
diff --git a/contrib/gcc/configure.in b/contrib/gcc/configure.in
index 448e0f8..e43c157 100644
--- a/contrib/gcc/configure.in
+++ b/contrib/gcc/configure.in
@@ -1399,9 +1399,9 @@ changequote(,)dnl
changequote([,])dnl
xm_file="xm-siglist.h xm-alloca.h ${xm_file}"
xm_defines="USG POSIX SMALL_ARG_MAX"
- if test x$stabs = xyes
- then
- tm_file=i386/sol2dbg.h
+ if test x$gas = xyes; then
+ # Only needed if gas does not support -s
+ tm_file=i386/sol2gas.h
else
tm_file=i386/sol2.h
fi
@@ -3103,12 +3103,21 @@ changequote([,])dnl
fi
;;
sparc-hal-solaris2*)
- xm_file=sparc/xm-sol2.h
+ xm_file="xm-siglist.h sparc/xm-sysv4.h sparc/xm-sol2.h"
+ xm_defines="USG POSIX"
tm_file="sparc/sol2.h sparc/hal.h"
tmake_file="sparc/t-halos sparc/t-sol2"
xmake_file=sparc/x-sysv4
extra_parts="crt1.o crti.o crtn.o gmon.o crtbegin.o crtend.o"
- broken_install=yes
+ case $machine in
+ *-*-solaris2.[0-4])
+ float_format=i128
+ ;;
+ *)
+ float_format=none
+ ;;
+ esac
+ thread_file='solaris'
;;
sparc-*-solaris2*)
if test x$gnu_ld = xyes
OpenPOWER on IntegriCloud